BrowserSync(前端利器-保存代码后,自动刷新浏览器)

摘要

Browsersync能让浏览器实时、快速响应您的文件更改(HTML、JavaScript、CSS、Sass、Less、PHP、Python等)并自动刷新页面。更重要的是 Browsersync可以同时在PC、平板、手机等设备下进项调试。您可以想象一下:“假设您的桌子上有pc、ipad、iphone、android等设备,同时打开了您需要调试的页面,当您使用browsersync后,您的任何一次代码保存,以上的设备都会同时显示您的改动”。无论您是前端还是后端工程师,使用它将提高您30%的工作效率。[1]

安装环境

  • Windows系统

下载与安装

下载安装 Node.js

因为BrowserSync是基于Node.js的, 是一个Node模块,所以使用之前需要安装Node.js

点击下载 Node.js

安装Node.js就像安装普通软件一样,此处省略安装流程

检查Node.js是否安装成功

(Windows使用CMD)输入命令行: node -v [用于查看Node.js是否安装成功,显示Node.js版本号,则表示安装成功。如图下所示:

$ node -v
v10.16.0

安装 BrowserSync

从Node.js的包管理(NPM[全称:Node.js Package Manager])库中安装BrowserSync
打开终端,输入以下命令行

npm install -g browser-sync

常见问题

错误:
....Unsupported platform for fsevents......

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm WARN glodon-satic-model@1.0.0 No repository field.

原因:
fsevent是在macOS下的依赖包,因为当前系统是Windows,因此只报warning信息[2]
解决方法:
Windows系统忽视该错误,即可。

参考


  1. http://www.caotama.com/90906.html ↩︎

  2. http://browsersync.cn ↩︎

posted @ 2020-03-17 19:56  扑街陈  阅读(539)  评论(0编辑  收藏  举报