摘要: 为什么需要类隔离加载 项目开发过程中,需要依赖不同版本的中间件依赖包,以适配不同的中间件服务端 如果这些中间件依赖包版本之间不能向下兼容,高版本依赖无法连接低版本的服务端,相反低版本依赖也无法连接高版本服务端 项目中也不能同时引入两个版本的中间件依赖,势必会导致类加载冲突,程序无法正常执行 解决方案 阅读全文
posted @ 2022-01-26 13:40 codest 阅读(481) 评论(0) 推荐(0) 编辑