01 2022 档案

摘要:为什么需要类隔离加载 项目开发过程中,需要依赖不同版本的中间件依赖包,以适配不同的中间件服务端 如果这些中间件依赖包版本之间不能向下兼容,高版本依赖无法连接低版本的服务端,相反低版本依赖也无法连接高版本服务端 项目中也不能同时引入两个版本的中间件依赖,势必会导致类加载冲突,程序无法正常执行 解决方案 阅读全文
posted @ 2022-01-26 13:40 codest 阅读(482) 评论(0) 推荐(0) 编辑
摘要:服务器配置信息 品牌:GreetWall CPU:飞腾FT-2000+/64 64bit 操作系统:Linux-4.19.90-24.4.v2101.ky10.aarch64-with-kylin-10-Sword 初次安装 安装包:yum install libvirt* qemu* virt-m 阅读全文
posted @ 2022-01-17 17:19 codest 阅读(2439) 评论(2) 推荐(0) 编辑
摘要:Spring Boot版本:2.6.2 查阅spring-boot-starter-mail源码的MimeMessageHelper.setText方法,发现有个Boolean类型参数控制是否是HTML格式,方法签名如下: public void setText(String text, boole 阅读全文
posted @ 2022-01-06 16:01 codest 阅读(131) 评论(0) 推荐(0) 编辑