1015 Reversible Primes (20 分)

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<105) and D (1<D10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

Submit:

#include <iostream>
#include <cmath>
using namespace std;

bool isPrime(int n){//判断是否是质数
    if (n <=1) return false;
    for (int i=2,j = (int)sqrt(n);i<=j;i++) {
        if (n%i == 0) return false;
    }
    return true;
}
//目标:质数对应进制的数字反转之后也是质数则输出yes
int main() {
    int n,d;
    while(scanf("%d", &n) != EOF){
        if (n < 0) break;//负数终止输入
        scanf("%d",&d);
        if(isPrime(n) == false){//n是质数进行转换进制
            printf("No\n");
            continue;
        }
        int a[100], len = 0;
        do{
            a[len++] = n % d;//进制转换
            n /= d;
        }while (n != 0);
        for(int i = 0; i < len; i++)
            n = n * d + a[i];
        printf(isPrime(n) ? "Yes\n" : "No\n");
    }
    return 0;
}

 

posted @ 2021-09-01 18:18  白玉神驹  阅读(36)  评论(0编辑  收藏  举报