作业头

这个作业属于哪个课程 C语言程序设计II
这个作业要求在哪里 https://edu.cnblogs.com/campus/zswxy/computer-scienceclass1-2018/homework/3238
我在这个课程的目标是 加油慢慢完成期末任务
这个作业在哪个具体方面帮助我实现目标 解决递归链表问题
参考文献 C语言教材 https://blog.csdn.net/weixin_44061561/article/details/85732857 https://blog.csdn.net/liujian20150808/article/details/79237284
6-1 计算最长的字符串长度 (15 分)

本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。
函数接口定义:

int max_len( char *s[], int n );

其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。
裁判测试程序样例:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

#define MAXN 10
#define MAXS 20

int max_len( char *s[], int n );

int main()
{
    int i, n;
    char *string[MAXN] = {NULL};

    scanf("%d", &n);
    for(i = 0; i < n; i++) {
        string[i] = (char *)malloc(sizeof(char)*MAXS);
        scanf("%s", string[i]);
    }
    printf("%d\n", max_len(string, n));

    return 0;
}
/* 你的代码将被嵌在这里 */

输入样例:

4
blue
yellow
red
green

输出样例:

6

实验代码:

int max_len( char *s[], int n )
{
    int i,max=0;
    for(i=0;i<n;i++)
    {
        if(max<strlen(s[i])){
            max=strlen(s[i]);
        }
    }
    return max;
}

流程图

本题没有遇到什么问题

6-2 统计专业人数 (15 分)

本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:

struct ListNode {
    char code[8];
    struct ListNode *next;
};

这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。
函数接口定义:

int countcs( struct ListNode *head );

其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。
裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct ListNode {
    char code[8];
    struct ListNode *next;
};

struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );

int main()
{
    struct ListNode  *head;

    head = createlist();
    printf("%d\n", countcs(head));
	
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1021202
2022310
8102134
1030912
3110203
4021205
#

输出样例:

3

实验代码

int countcs( struct ListNode *head ) { 
    int num=0;
    while(head!=NULL){
    if(head->code[1] == '0' && head->code[2] == '2')
       num++;
       head=head->next;
    }
    return num;
}


遇到的问题
对于链表的头指针和头结点仍存在混淆概念
6-3 删除单链表偶数节点 (20 分)

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:

struct ListNode {
    int data;
    struct ListNode *next;
};

函数接口定义:

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );

函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。
裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct ListNode {
    int data;
    struct ListNode *next;
};

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
     struct ListNode *p = head;
     while (p) {
           printf("%d ", p->data);
           p = p->next;
     }
     printf("\n");
}

int main()
{
    struct ListNode *head;

    head = createlist();
    head = deleteeven(head);
    printlist(head);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1 2 2 3 4 5 6 7 -1
输出样例:
1 3 5 7  

实验代码

struct ListNode *createlist(){
    int data;
    int size = sizeof(struct ListNode);
    struct ListNode *head,*tail,*p;
    head=tail=NULL;
    scanf("%d",&data);
    while(data!=-1){
        p=(struct ListNode *)malloc(size);
        p->data=data;
        p->next=NULL;
        if(head==NULL)
           head=p;
        else
           tail->next=p;
           tail=p;
        scanf("%d",&data);
    }
    return head;
}
struct ListNode *deleteeven( struct ListNode *head )
{
    int i=0;
    struct ListNode *ptr1=head,*p=head->next;
    if(head==NULL)
       p=NULL;
    if(head->data%2==0&&p==NULL)
       head=NULL;
    if(p!=NULL){
    while(p!=NULL)
    {
    if(p->data%2==0)
       ptr1->next=p->next;
    else
       ptr1=ptr1->next;
       p=p->next;
       i++;
    if(i==1&&p==NULL||i==2&&p==NULL)
       return head; 
    }
    if((i!=1&&p==NULL||i!=2&&p==NULL)&&head->data%2==0)
        return head->next;
    else if(i!=1&&p==NULL||i!=2&&p==NULL)
        return head;
    } 
    else
        return head;
}

本题没多大思路 在查阅相关题目后借鉴了一些代码 链接:https://blog.csdn.net/weixin_44061561/article/details/85732857