崔伊平  

最近在研究redis的集群,redis官方提供了redis-trib.rb工具,但是在使用之前 需要安装ruby,以及redis和ruby连接:

yum -y install ruby ruby-devel rubygems rpm-build

gem install redis

其中 gem install redis命令执行时出现了:

 redis requires Ruby version >= 2.2.2的报错,查了资料发现是Centos默认支持ruby到2.0.0,可gem 安装redis需要最低是2.2.2

解决办法是 先安装rvm,再把ruby版本提升至2.3.3

1.安装curl

sudo yum install curl

2. 安装RVM

curl -L get.rvm.io | bash -s stable 

3. 

source /usr/local/rvm/scripts/rvm

4. 查看rvm库中已知的ruby版本

rvm list known

5. 安装一个ruby版本

rvm install 2.3.3

6. 使用一个ruby版本

rvm use 2.3.3

7. 设置默认版本

rvm remove 2.0.0

8. 卸载一个已知版本

ruby --version

9. 再安装redis就可以了

gem install redis

 

 

 

 参考博客:

http://blog.csdn.net/lixwjava/article/details/50408070 

http://blog.csdn.net/fengye_yulu/article/details/77628094 

 

 

 

posted on 2017-08-29 13:33 崔伊平 阅读(...) 评论(...) 编辑 收藏
 
Copyright © 2019 崔伊平
Powered by .NET Core 3.0 Preview 8 on Linux
Powered by: 博客园 模板提供:沪江博客
博客园