POJ 3278 Catch That Cow(求助大佬)

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 109702   Accepted: 34255

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

思路:简单的宽搜,但是改了很长时间。
求大佬指正:这里哪儿有问题呢?
void bfs(){
    while(!que.empty())    que.pop();
    nond tmp;tmp.pos=x;tmp.step=0;
    vis[x]=1;que.push(tmp);
    while(!que.empty()){
        nond now=que.front();
        que.pop();nond a,b,c;
        c.pos=now.pos+1;c.step=now.step+1;if(now.pos<=y&&!vis[c.pos])    que.push(c),vis[c.pos]=1;
        if(c.pos==y){ printf("%d\n",c.step);return ; }
        a.pos=now.pos-1;a.step=now.step+1;if(now.pos>=1&&!vis[a.pos])    que.push(a),vis[a.pos]=1;
        if(a.pos==y){ printf("%d\n",a.step);return ; }
        b.pos=now.pos*2;b.step=now.step+1;if(now.pos<=y&&!vis[b.pos])    que.push(b),vis[b.pos]=1;
        if(b.pos==y){ printf("%d\n",b.step);return ; }
    }
}

像上面那样写就不行,改成下面这样就AC了。

#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int x,y;
int vis[500000];
struct nond{ int pos,step; };
queue<nond>que;
void bfs(){
    while(!que.empty())    que.pop();
    nond tmp;tmp.pos=x;tmp.step=0;
    vis[x]=1;que.push(tmp);
    while(!que.empty()){
        nond now=que.front();
        que.pop();nond a,b,c;
        if(now.pos==y){ printf("%d\n",now.step);return ; }
        c.pos=now.pos+1;c.step=now.step+1;if(now.pos<=y&&!vis[c.pos])    que.push(c),vis[c.pos]=1;
        a.pos=now.pos-1;a.step=now.step+1;if(now.pos>=1&&!vis[a.pos])    que.push(a),vis[a.pos]=1;
        b.pos=now.pos*2;b.step=now.step+1;if(now.pos<=y&&!vis[b.pos])    que.push(b),vis[b.pos]=1;
    }
}
int main(){
    while(scanf("%d%d",&x,&y)!=EOF){
        memset(vis,0,sizeof(vis));
        bfs();
    }
}

 

posted @ 2018-04-14 09:17  一蓑烟雨任生平  阅读(135)  评论(0编辑  收藏  举报