POJ1218

                               Problem  C

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 9   Accepted Submission(s) : 8
Problem Description
A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked. One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He repeats this for n rounds, takes a final drink, and passes out. Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape. Given the number of cells, determine how many prisoners escape jail.
 
Input
The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n.
 
Output
For each line, you must print out the number of prisoners that escape when the prison has n cells.
 
Sample Input
2
5
100
 
Sample Output
2
10
#include<stdio.h>
#include<string.h>
int main()
{
    int t,n,i,s,m,j,k;
    scanf("%d",&t);
    while(t--)
    {
          k=0;
       scanf("%d",&n);
        for(i=1;i<=n;i++)
        {s=0;
         for(j=1;j<=i;j++)
         {
             if(i%j==0)
               s++;
         }
         if(s%2!=0)
           k++;
        }
        printf("%d\n",k);
    }
       return 0;
    }

 

posted @ 2013-11-30 22:19  疯狂的癫子  阅读(209)  评论(0编辑  收藏  举报