HDU-2522 A simple problem

http://acm.hdu.edu.cn/showproblem.php?pid=2522

学习://除数的运算的应用和算法。除法的本质,如果余数出现重复就表示有循环节

                  A simple problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2795    Accepted Submission(s): 984

Problem Description
Zty很痴迷数学问题.。一天,yifenfei出了个数学题想难倒他,让他回答1 / n。但Zty却回答不了^_^.  请大家编程帮助他.
 
Input
第一行整数T,表示测试组数。后面T行,每行一个整数 n (1<=|n|<=10^5).
 
Output
输出1/n. (是循环小数的,只输出第一个循环节).
 
Sample Input
4
2
3
7
168
Sample Output
0.5
0.3
0.142857
0.005952380
//除数的运算的应用和算法。除法的本质,如果余数出现重复就表示有循环节  
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int f[100000],mark[100000];
int main()
{
	int t,n,y,cnt,i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		if(n<0)//如果是负数
		{
			printf("-"); //首先打印负号   
			n=-1*n;//取反后当做正数处理 
		}
		if(n==1)
		{
			printf("1\n");
				continue;
		}
	      cnt=0;
		    y=1;
			memset(mark,0,sizeof(mark));
			mark[1]=1;//当余数为1时也会有是循环的出现。不要丢。
		  while(y)
		  {
			  y=y*10;
              f[cnt++]=y/n;
			  y=y%n;
			  if(mark[y])//如果使用过,说明出现循环数节
				  break;
			  mark[y]=1;//记录余数是否使用过  
		  }
		  printf("0.");
		  for(i=0;i<cnt;i++)
			  printf("%d",f[i]);
          printf("\n");
		}
	
	return 0;
}

 

posted @ 2013-11-25 20:57  疯狂的癫子  阅读(174)  评论(0编辑  收藏  举报