HDU-2141 Can you find it?

学习二分查找+排序。一定用c++程序 sort用法;    

    http://acm.hdu.edu.cn/showproblem.php?pid=2141        

                       Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others) Total Submission(s): 8557    Accepted Submission(s): 2230

Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
 
Sample Output
Case 1:
NO
YES
NO
#include <iostream>
#include <algorithm>
using namespace std;
int a[505],b[505],c[505],sab[250005];
int find( int a, int l , int h )//二分查找
{
 if( l > h )
  return 0;
 int mid = ( l + h ) / 2;
 if ( sab[mid] == a )
    return 1;
 else if( sab[mid] > a)
    find ( a, l, mid-1);
 else
     find ( a, mid+1, h);
}
int main()
{
	int r,i,j,l,n,m,s,x,y,t=1;
	while(~scanf("%d%d%d",&l,&n,&m))
	{
		     r=0;
		for(i=0;i<l;i++)
			scanf("%d",&a[i]);
		for(i=0;i<n;i++)
			scanf("%d",&b[i]);
		for(i=0;i<m;i++)
			scanf("%d",&c[i]);
        for(i=0;i<l;i++)
		  for(j=0;j<n;j++)
			 sab[r++]=a[i]+b[j];
         sort(sab,sab+r);//排序
        scanf("%d",&s);
		printf("Case %d:\n",t++);
		while(s--)
		{
			y=0;
			scanf("%d",&x);
			for(i=0;i<m;i++)
			{
                 y=find(x-c[i],0,r-1);
				 if(y==1)
					  break;
			}
			
			if(y==1)
				printf("YES\n");
			else
				printf("NO\n");
		}
	}
	return 0;
}

 

 
posted @ 2013-11-24 21:39  疯狂的癫子  阅读(130)  评论(0编辑  收藏  举报