PTA 词频统计(30 分)

词频统计(30 分)

请编写程序,对一段英文文本,统计其中所有不同单词的个数,以及词频最大的前10%的单词。

所谓“单词”,是指由不超过80个单词字符组成的连续字符串,但长度超过15的单词将只截取保留前15个单词字符。而合法的“单词字符”为大小写字母、数字和下划线,其它字符均认为是单词分隔符。

输入格式:

输入给出一段非空文本,最后以符号#结尾。输入保证存在至少10个不同的单词。

输出格式:

在第一行中输出文本中所有不同单词的个数。注意“单词”不区分英文大小写,例如“PAT”和“pat”被认为是同一个单词。

随后按照词频递减的顺序,按照词频:单词的格式输出词频最大的前10%的单词。若有并列,则按递增字典序输出。

输入样例:

This is a test.

The word "this" is the word with the highest frequency.

Longlonglonglongword should be cut off, so is considered as the same as longlonglonglonee.  But this_8 is different than this, and this, and this...#
this line should be ignored.

输出样例:(注意:虽然单词the也出现了4次,但因为我们只要输出前10%(即23个单词中的前2个)单词,而按照字母序,the排第3位,所以不输出。)

23
5:this
4:is

#include<stdio.h>  
#include<iostream>  
#include<string>  
#include<algorithm>  
#include<vector>  
using namespace std;  
struct node{  
    string s;  
    int n;  
};  
vector<node > q;  
bool cmp(node s1,node s2)  
{  
    if(s1.n ==s2.n )  
    return s1.s <s2.s ;  
    else  
    return s1.n >s2.n;   
}  
//比较如果词频一样,按字符从小到大排;   
int main()  
{  
    char n;  
    string s;  
    while(scanf("%c",&n))  
    {  
        if(n>='A'&&n<='Z'||n>='a'&&n<='z'||n>='0'&&n<='9'||n=='_')  
        {  
            if(n>='A'&&n<='Z')  
            n=n+32;  
            s+=n;//string可以直接相加   
        }//进行大小写转化,并累加字母为单词;   
        else  
        if(n=='#'||s.size()>0)  
        {  
            string ss;  
            if(s.size()>0)  
            {  
                int g=0;  
                for(int i=0;i<15&&i<s.size();i++)  
                {  
                    ss+=s[i];  
                }  
                for(int i=0;i<q.size();i++)  
                {  
                    if(q[i].s==ss)  
                    q[i].n++;//记录单词个数;   
                    g=1;  
                }  
                if(g==0)  
                {  
                    node cc ;  
                    cc.n = 1;  
                    cc.s = ss;  
                    q.push_back(cc);  
                }//如果是新单词,新记录;   
            }  
            s.clear();  
            //每次都空;   
            if(n=='#')  
            {  
                break;  
            }  
        }  
    }  
    printf("%d\n",q.size());//单词数   
    sort(q.begin(),q.end(),cmp);//进行排序   
    for(int i=0;i<q.size()/10;i++)  
    printf("%d:",q[i].n),cout<<q[i].s,printf("\n");  
}  

 

 
posted on 2018-03-12 23:14  蔡军帅  阅读(2843)  评论(0编辑  收藏  举报