2017杭电多校第七场1005Euler theorem

Euler theorem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
HazelFan is given two positive integers a,b, and he wants to calculate amodb. But now he forgets the value of b and only remember the value of a, please tell him the number of different possible results.
 

Input
The first line contains a positive integer T(1T5), denoting the number of test cases.
For each test case:
A single line contains a positive integer a(1a109).
 

Output
For each test case:
A single line contains a nonnegative integer, denoting the answer.
 

Sample Input
2 1 3
 

Sample Output
2 3
 

Statistic | Submit | Clarifications | Back

思路:找规律
#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int main()
{
    int t;
    int a;
    cin>>t;
    while(t--)
    {
        cin>>a;
        int temp=(a+1)/2;
        if(a==1)cout<<2<<endl;
        else if(a==2)cout<<1<<endl;
        else if(a==3)cout<<3<<endl;
        else
        {
            cout<<temp+1<<endl;
        }
    }
    return 0;
}



posted @ 2017-08-15 22:18  Bryce1010  阅读(74)  评论(0编辑  收藏  举报