(HDU 4405) Aeroplane chess (概率DP)

Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 
 

 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

 

Sample Input
2 0 8 3 2 4 4 5 7 8 0 0
 

 

Sample Output
1.1667 2.3441
 

 每次投一个色子,所以有6种不同的转移可能。

如果i位置不是一条航线的起点,那么:

dp[i]=(dp[i+1]+dp[i+2]+dp[i+3]+dp[i+4]+dp[i+5]+dp[i+6])/6+1;

否则(i到j有一条航线):

dp[i]=dp[j](飞行可以不投色子);

dp[0]就是答案;

#include<iostream>
#include<cstdio>
#include<vector>
#include<set>
#include<map>
#include<string.h>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
#define LL long long
#define mod 1000000007
#define inf 0x3f3f3f3f

using namespace std;
int a[100010];
double dp[100010];

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        memset(dp,0,sizeof(dp));
        memset(a,0,sizeof(a));
        for(int i=1;i<=m;i++)
        {
            int p,q;
            scanf("%d%d",&p,&q);
            a[p]=q;
        }
        for(int i=n-1;i>=0;i--)
        {
            if(a[i]!=0)
                dp[i]=dp[a[i]];
            else
            {
                double sum=1;
                for(int j=1;j<=6;j++)
                    sum+=(dp[i+j]/6);
                dp[i]=sum;
            }
        }
        printf("%.4lf\n",dp[0]);
    }
    return 0;
}

 

posted @ 2018-02-08 17:40  海哥天下第一  阅读(120)  评论(0编辑  收藏  举报