Boostable

  博客园  :: 首页  :: 新随笔  :: 联系 :: 订阅 订阅  :: 管理
Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

 

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9 
Sample Output
-999,991 

主要注意两点 :

  1. 输出时要注意逗号,如1000要输出1,000
  2. 要注意后面部分数字的前置0,如1010,要输出1,010,而不是1,10
代码
 1 #include <stdio.h>
 2 int main()
 3 {
 4     int a,b,sum;
 5     int arr[5];
 6     while(scanf("%d%d",&a,&b) != EOF){
 7         sum = a+b;
 8         if(sum == 0){
 9             printf("0\n");
10             break;
11         }
12         else if(sum < 0){
13             printf("-");
14             sum = sum * -1;
15         }
16         int i = 0;
17         while(sum){
18             arr[i++] = sum % 1000;
19             sum = sum / 1000;
20         }
21         printf("%d",arr[--i]);
22         for(--i;i >= 0;--i){
23             printf(",%03d",arr[i]);
24         }
25         printf("\n");
26     }
27     return 0;
28 }

 

posted on 2014-02-07 23:12  Boostable  阅读(237)  评论(0编辑  收藏  举报