1094.String matching

题目描述:
    Finding all occurrences of a pattern in a text is a problem that arises frequently in text-editing programs. 
    Typically,the text is a document being edited,and the pattern searched for is a particular word supplied by the user.  
    We assume that the text is an array T[1..n] of length n and that the pattern is an array P[1..m] of length m<=n.We further assume that the elements of P and  T are all alphabets(∑={a,b...,z}).The character arrays P and T are often called strings of characters.  
    We say that pattern P occurs with shift s in the text T if 0<=s<=n and T[s+1..s+m] = P[1..m](that is if T[s+j]=P[j],for 1<=j<=m).  
    If P occurs with shift s in T,then we call s a valid shift;otherwise,we calls a invalid shift. 
    Your task is to calculate the number of vald shifts for the given text T and p attern P.
输入:
   For each case, there are two strings T and P on a line,separated by a single space.You may assume both the length of T and P will not exceed 10^6. 
输出:
    You should output a number on a separate line,which indicates the number of valid shifts for the given text T and pattern P.
样例输入:
abababab abab
样例输出:

3

 

#include<stdio.h>
#include<string.h>
using namespace std;

int main(){
    char a[100001],b[100001];
    while(scanf("%s %s",a,b)!=EOF){
        int num=0,i,j;
        int len1=strlen(a);
        int len2=strlen(b);
        for(i=0;i<=len1-len2;i++){
            int flag=1;
            for(int j=0;j<len2;j++){
                if(a[i+j]!=b[j]) flag=0;
            }
            if(flag==1) num++;
        }
         printf("%d\n",num);
    }
    return 0;
}

 

posted @ 2018-10-02 10:24  bernieloveslife  阅读(241)  评论(0编辑  收藏  举报