1092.Fibonacci

题目描述:

    The Fibonacci Numbers{0,1,1,2,3,5,8,13,21,34,55...} are defined by the recurrence: 
    F0=0 F1=1 Fn=Fn-1+Fn-2,n>=2 
    Write a program to calculate the Fibonacci Numbers.

输入:

    Each case contains a number n and you are expected to calculate Fn.(0<=n<=30) 。

输出:

   For each case, print a number Fn on a separate line,which means the nth Fibonacci Number.

样例输入:
1
样例输出:
1
#include<iostream>
using namespace std;

int f(int x){
    if(x==0) return 0;
    else {
    if(x==1) return 1;
    else {
    int a=f(x-1)+f(x-2);
    return a;
}
}
}

int main(){
    int n;
    while(cin>>n){
            cout<<f(n)<<endl;
        }
    return 0;
}

 

posted @ 2018-10-02 10:22  bernieloveslife  阅读(186)  评论(0编辑  收藏  举报