baker95935

  博客园  :: 首页  :: 新随笔  :: 联系 :: 订阅 订阅  :: 管理
上一页 1 ··· 35 36 37 38 39 40 41 42 43 ··· 50 下一页

2017年12月29日

摘要: Jenkins 是一个可扩展的持续集成引擎。 主要用于: l 持续、自动地构建/测试软件项目。 l 监控一些定时执行的任务。 Jenkins拥有的特性包括: l 易于安装-只要把jenkins.war部署到servlet容器,不需要数据库支持。 l 易于配置-所有配置都是通过其提供的web界面实现。 阅读全文
posted @ 2017-12-29 11:10 baker95935 阅读(640) 评论(0) 推荐(0)

2017年12月28日

摘要: 转载请注明出处:http://blog.csdn.net/seu_calvin/article/details/52354964 0. 前言 Dalvik是Google公司自己设计用于Android平台的虚拟机。Dalvik经过优化,使其更适合Android平台。具体优点会在下面和JVM进行比较时说 阅读全文
posted @ 2017-12-28 17:23 baker95935 阅读(465) 评论(0) 推荐(0)

摘要: 练手写的shell脚本,可自动下载apache,然后切换到apache的目录 如果在加上编译 和安装 就是可以自动完成了 if语句里面的几个参数标注下 1)-z 就是为空 2)$1 就是第一个参数 $2就是在命令行中输入的第2个参数 比如 /bin/bash auto_install_httpd.s 阅读全文
posted @ 2017-12-28 11:06 baker95935 阅读(575) 评论(0) 推荐(0)

2017年12月27日

摘要: 之前看的各种面试,貌似都有shell脚本编程,没了解之前感觉很复杂,现在了解了些,没想象中那么难。 逻辑主要是这样的 编写.sh的脚本文件,文件里面的代码,就是在命令行输入的可执行命令的加强版,所谓加强版就是有些支持参数或者变量。 比如1.sh 想实现安装httpd 最简洁的代码可以是 SOFT=" 阅读全文
posted @ 2017-12-27 16:52 baker95935 阅读(192) 评论(0) 推荐(0)

摘要: 动静分离逻辑梳理 就是给nginx配置访问规则,不同后缀的文件访问不同的目录 阅读全文
posted @ 2017-12-27 11:47 baker95935 阅读(197) 评论(0) 推荐(0)

2017年12月26日

摘要: Keepalived的作用是检测服务器的状态,如果有一台web服务器宕机,或工作出现故障,Keepalived将检测到,并将有故障的服务器从系统中剔除,同时使用其他服务器代替该服务器的工作,当服务器工作正常后Keepalived自动将服务器加入到服务器群中,这些工作全部自动完成,不需要人工干涉,需要 阅读全文
posted @ 2017-12-26 10:55 baker95935 阅读(271) 评论(0) 推荐(0)

2017年12月25日

摘要: 1 先安装tornado 2 新建tor.py 记住不能建立 tornado.py 这样的名字 不然会报错 ImportError: No module named 'tornado.ioloop'; 'tornado' is not a package 3 运行文件 在命令行中输入 命令 pyth 阅读全文
posted @ 2017-12-25 16:17 baker95935 阅读(1814) 评论(0) 推荐(0)

摘要: mysql主从复制的原理 mysql master服务器,开启bin-log日志,开启IO线程 slave服务器,开启IO线程,开启SQL线程(执行SQL) 1)slave服务器,通过授权用户开启IO线程,连接master,并且从指定位置开始请求bin-log日志的内容。 2)master服务器,接 阅读全文
posted @ 2017-12-25 11:07 baker95935 阅读(153) 评论(0) 推荐(0)

2017年12月21日

摘要: 最近做了几个小时的调研,微信小程序 微信小程序是可以理解成在微信中的APP,他的目标是APP的替代者,由于目前的APP主要区分安卓和IOS,或者其他平台, 那么微信小程序的平台在微信,在任何一个手机系统中打开了微信,那么微信小程序就可以运行。所以解决了平台的问题。 而且一个APP,都有分别下载和安装 阅读全文
posted @ 2017-12-21 14:29 baker95935 阅读(1106) 评论(0) 推荐(0)

摘要: 关于RDS中导入数据库set global event_scheduler =1 需要更多超级权限 报错提示 其实这个意思是 让mysql自动启动 计划任务 如果在 命令行下 查询 SHOW VARIABLES LIKE 'event_scheduler' 看到 event_scheduler =O 阅读全文
posted @ 2017-12-21 11:44 baker95935 阅读(3090) 评论(0) 推荐(0)

上一页 1 ··· 35 36 37 38 39 40 41 42 43 ··· 50 下一页