hdu Leftmost Digit

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1338    Accepted Submission(s): 627
 
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the leftmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
2
2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 
Author
Ignatius.L

分析:重要数学技巧,将数对10取对数后的小数部分就是该数写成科学计数法时的那个小数对10取对数。

#include<cstdio>
#include<cmath>

int main() {
    int T;
    double ans, n;
    scanf("%d", &T);
    while (T--) {
        scanf("%lf", &n);
        ans = n * log10(n);
        ans -= (long long) ans;
        printf("%d\n", (int) pow(10, ans));
    }
    return 0;
}

 

 

posted @ 2012-08-30 03:43  YogyKwan  阅读(172)  评论(0编辑  收藏  举报