Ubuntu9.10 安装mono MonoDevelop

这几天在玩mono

//安装必需的包,以免编译出错

sudo apt-get install build-essential #这将安装gcc/g++/gdb/make 等基本编程工具

sudo apt-get update

下载mono-2.6.3 http://ftp.novell.com/pub/mono/sources/mono/

wget http://ftp.novell.com/pub/mono/sources/mono/mono-2.6.3.tar.bz2

下载完了,解压

tar jvxf mono-2.6.3.tar.bz2

cd mono-2.6.3

 ./configure --prefix=/usr

如果提示缺少bison

sudo apt-get install bison

如果提示缺少gettext

sudo apt-get install gettext

如果提示缺少glib-2.0

sudo apt-get install libglib2.0-dev

如果成功

make

sudo make install

编译的时候需要花费点时间

安装完了打 mono -V 看看是否显示mono版本

我的是2.6.3

sudo apt-get install pkg-config #用于在编译GTK程序时自动找出头文件及库文件位置

 

现在开始安装 gtk-sharp

我下的版本是gtk-sharp-2.12.10.tar.bz2

http://ftp.novell.com/pub/mono/sources/gtk-sharp212/gtk-sharp-2.12.10.tar.bz2

编辑一半是提示找不到 pango包

google了以下,输入以下命令

sudo apt-get install build-essential libgtk2.0-dev

安好了

下一步安MonoDevelop http://ftp.novell.com/pub/mono/sources/monodevelop/monodevelop-2.2.2.tar.bz2

跟上面的一样编译

tar jvxf monodevelop-2.2.2.tar.bz2

cd monodevelop-2.2.2

 ./configure --prefix=/usr

make

sudo make install

 

好了,安装完了
安monodevelop-2.2.2还比较顺利,主要是安mono有点麻烦,依赖的包太多了

 

 

 

 

posted @ 2010-04-24 16:21 petersun 阅读(...) 评论(...) 编辑 收藏