网络设备基本配置(思科版本)

来源于:https://www.cnblogs.com/jarick-jiao/p/7831686.html


 

1查看IP地址的配置信息

右击桌面网络图标—属性—更改适配器设置—双击本地连接—单击"详细信息

或者开始 | 命令提示符 | 运行cmd |

ipconfig或Ipconfig /all查看MAC地址

 

2 ping 命令测试网络连通性

Ping 127.0.0.1

进行回环测试

验证TCP/IP配置是否正确

 

3 交换机的工作模式:

Switch>用户模式

Switch>enable

Switch#特权模式

Switch#configure terminal

Switch(config)#全局配置模式

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#接口模式

exit返回上一模式

end直接退到特权模式

常用命令:

接口模式:shutdown禁用此接口

Switch(config)#hostname S1修改主机名为S1

Switch#show running-config查看配置信息

Switch#show version查看IOS版本信息

配置enable明文口令:全局配置模式:enable password 123

配置enable加密口令:全局配置模式: enable secret 456

配置Console口令:全局模式:line console 0 password 789 Login

保存交换机的配置

特权: copy running-config startup-config 或 write

恢复设备出厂默认值

特权:erase startup-config 或 reload

 

4 设备配置的准备工作

空闲一段时间后,重回初始界面的问题

switch(config)#line con 0

switch(config-line)#exec-timeout 0 0

控制台消息打断输入的处理

switch(config)#line con 0

switch(config-line)#logging synchronous

禁用DNS查询

switch(config)#no ip domain-lookup

 

5 交换机的基本配置

1、常用命令

1)查看MAC地址表

特权:show mac-address-table

2)使用CDP协议

用来查看邻居Cisco设备的信息

特权:show cdp neighbors

3)接口的工作模式配置

指定接口的双工模式

接口模式:duplex {full | half | auto}

full(全双工)、Half(半双工)、Auto(自动协商)

指定接口的通信速率

接口模式:speed {10 | 100 | 1000 | auto}

查看以太网接口的双工模式和通信速率

特权:show interface fastethernet 0/24

4)配置管理用IP地址

Console不是唯一的管理手段,有时需要通过网络对设备进行远程管理

配置管理用IP地址 : 全局配置模式:interface vlan 1

ip address 192.168.1.100 255.255.255.0 no shutdown

5)配置交换机默认网关

全局配置模式:

ip default-gateway 192.168.1.254

 

6 网络层协议

ARP协议

将一个已知的IP地址解析成MAC地址

Windows系统中的ARP -a:查看ARP缓存表

Ping 命令的常用参数:

Ping -t 一直ping

Ping -a 可以返回对方主机名

Ping -l修改ping包大小,默认32字节

 

7 静态路由配置

全局模式:ip route 目标网络ID 子网掩码 下一跳IP

 

8 telnet远程管理操作

在主机上操作 〔开始〕-〔运行〕-cmd

telnet 远程主机的IP 〔端口号〕

远程管理交换机或路由器

配置交换机管理IP : 全局: line vty 0 4

password 123

login

全局模式配置明文或密文密码之一

配置客户机IP并telnet 交换机管理IP

远程管理路由器的配置不同之处是给路由器的接口配置IP其他都相同

9 创建VLAN有两种方法

全局配置模式创建vlan

全局:vlan 2创建vlan2 Name 名字(给vlan2命名)

VLAN数据库配置模式

特权:vlan database Vlan 2 name caiwu(创建vlan2并命名为caiwu)

删除vlan

进入vlan数据库或全局模式:no vlan 2

接口加入vlan

1)进入将要加入vlan的接口然后输入

2)同时将多个接口加入vlan

全局: interface range f0/1 – 10

switchport access vlan 2将1-10口同时加入vlan2

查看vlan信息

特权:show vlan brief

 

10 trunk的配置

接口模式:switchport mode trunk(直接配置为trunk)

dynamic desirable (配置为动态企望)

dynamic auto(动态自动)

access(配置为接入链路)

在trunk链路上移除某vlan

进入trunk接口:switchport trunk allowed vlan remove 3中继链路不允许传送vlan 3的数据

在trunk链路上 添加某vlan

进入trunk接口:switchport trunk allowed vlan add 3

查看接口模式

特权:show interface f0/5 switchport

 

11 以太网通道的配置:

全局:interface range f0/6 – 8

switchport mode trunk

channel-group 1 mode on

查看以太网通道的配置:

特权:show etherchannel summary

 

12 在路由器上配置DHCP服务

全局ip dhcp pool 名字(定义地址池)

network 192.168.1.0 255.255.255.0(动态分配IP地址段)

default-router 192.168.1.254(动态分配的网关地址)

dns-server 202.106.0.20(动态分配的DNS服务器地址)此命令后可以跟多个备用的DNS地址。

全局:ip dhcp excluded-address 192.168.1.1(预留已静态分配的IP地址)

13 三层交换机的配置

在三层交换机启用路由功能 全局:ip routing

配置虚拟接口的IP 地址 全局:interface vlan 2

ip address 192.168.2.254 2 55.255.255.0

no shutdown

在三层交换机上配置Trunk并指定接口封装为802.1q

接口模式:switchport trunk encapsulation dot1q

switchport mode trunk

配置路由接口 进入接口:no switchport

 

14 RIP v2的配置

全局:router rip version 2 no auto-summary(关闭路由汇总)

network 主网络ID

15 HSRP的配置

配置为HSRP的成员

进入路由器的网关接口:standby 2 ip 虚拟网关IP

配置HSRP的优先级

standby priority 优先级(优先级范围0-255,默认为100)

查看HSRP摘要信息 特权: show standby brief

HSRP端口跟踪 :standby 2 track f0/1

HSRP占先权    :standby preempt

 

16 PVST+的配置命令

启用生成树命令

全局:spanning-tree vlan 2

指定根网桥

改优先级 :全局:spanning-tree vlan priority 优先级的值

注意: 优先级的值是4096的倍数;

查看生成树的配置 特权:show spanning-tree vlan 1

直接指定 全局:spanning-tree vlan root primary/secondary

配置速端口 :接口模式:spanning-tree portfast

查看某个VLAN的生成树详细信息

特权:show spanning-tree vlan 2 detail

 

17 标准访问控制列表

(1)标准访问控制列表的创建

全局:access-list 1 deny 192.168.1.1 0.0.0.0

全局:access-list 1 permit 192.168.1.0 0.0.0.255

隐含拒绝语句:

access-list 1 deny 0.0.0.0 255.255.255.255

将ACL应用于接口: 接口模式:ip access-group 列表号 in或out

注:access-list 1 deny 192.168.1.1 0.0.0.0或写为

access-list 1 deny host 192.168.1.1

access-list 1 deny 0.0.0.0 255.255.255.255

或写为access-list 1 deny any

删除已建立的访问控制列表: 全局:no access-list 列表号

接口上取消ACL: 接口模式:no ip access-group 列表号in 或out

查看访问控制列表: 特权:show access-lists

eq等于、lt小于、gt大于、neq不等于

(2)扩展访问控制列表案例:

例1:全局: access-list 101 permit ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255(允许192.168.1.0网络访问192.168.2.0网络的所有服务)

全局: access-list 101 deny ip any any(拒绝所有)

例2:全局: access-list 101 deny tcp 192.168.1.0 0.0.0.255 host 192.168.2.2 eq 21 (拒绝192.168.1.0网段访问192.168.2.2的TCP的21端口)

全局:access-list 101 permit ip any any(允许访问所有)

例3全局: access-list 101 deny icmp 192.168.1.0 0.0.0.255 host 192.168.2.2 echo (拒绝192.168.1.0 ping 192.168.2.2)

删除扩展ACL全局:no access-list 列表号

(3)标准命名ACL的配置: 全局:ip access-list standard 名字

Permit host 192.168.1.1

deny any

命名ACL应用于接口:接口模式:ip access-group 名字 in或out

(4)扩展命名ACL的配置: 全局:ip access-list extended 名字

deny tcp 192.168.1.0 0.0.0.255 host 192.168.2.2 eq 80拒绝1.0网段访问2.2的web服务。

Permit ip any any

 

18 静态NAT配置:

配置接口IP及路由: 全局:Ip nat inside source static 192.168.1.1 61.159.62.131

在内外接口上启用NAT:进入出口配置:ip  nat  outside

进入入口配置:ip  nat  inside

端口映射:ip nat inside source static tcp 192.168.1.6 80 61.159.62.133 80

动态NAT的配置:全局:access-list 1 permit 192.168.1.0 0.0.0.255

全局:ip nat pool nsd 61.159.62.131 61.159.62.132 netmask 255.255.255.248(定义地址池名称为nsd,地址池IP范围61.159.62.131 到61.159.62.132)

全局:ip nat inside source list 1 pool nsd

show ip nat translations

端口多路复用(PAT)

PAT的配置:全局:ip nat inside source list 1 interface f0/1 overload

查看NAT转换条目: 特权:show ip nat translations显示当前存在的转换清除NAT转换条目: 特权: clear ip nat translation * 清除NAT转换条目中的所有所条目

显示每个转换的数据包: 特权:debug ip nat

posted @ 2019-03-11 23:08 北极边界安全团队 阅读(...) 评论(...) 编辑 收藏