训练1-Y

对于给定的一个字符串,统计其中数字字符出现的次数。

Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串

Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。

Sample Input
2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf
Sample Output
6
9
#include<stdio.h>
#include<string.h>
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		char a[100];
		scanf("%s",a);
		int i=0,sum=0;
		while(a[i]!='\0'&&i<strlen(a))
		{
			if(a[i]<='9'&&a[i]>='0')
			sum++;
			i++;
		}
		printf("%d\n",sum);
	}
	return 0;
 } 

...

posted @ 2018-06-05 17:42  浮生惘语  阅读(133)  评论(0编辑  收藏  举报