POJ 1002 487-3279(字典树/map映射)

487-3279
Time Limit: 2000MS        Memory Limit: 65536K
Total Submissions: 309257        Accepted: 55224
Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 
Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 
Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279
Sample Output

310-1010 2
487-3279 4
888-4567 3


题意:按照对应规则将字符串转化为标准格式的电话号码和出现次数,出现次数小于2不输出,无输出则输出No duplicates. 


法一:全部转化数字后建字典树,最后一个节点记录次数,建完后dfs遍历到尾结点输出串

#include<iostream>
#include<string.h>
#include<map>
using namespace std;
int vis[222222];
int t[222222][22];
char str[222];
int flag,pos=0;
void insert(char *s)
{
    int rt=0;
    int len=strlen(s);
    for(int i=0;i<len;i++)
    {
        int x;
        if(s[i]=='-')continue;
        if(s[i]>='0'&&s[i]<='9')
            x=s[i]-'0';
         else if(s[i]>='A'&&s[i]<='Z')
         {
             if(s[i]<'Q')
                x=(s[i]-'A')/3+2;
             else if(s[i]>'Q')
                x=(s[i]-'B')/3+2;
         }
         if(t[rt][x]==0)
            t[rt][x]=++pos;
          rt=t[rt][x];
    }
    vis[rt]++;
}
void dfs(int rt,int deep)
{
    for(int i=0;i<=9;i++)
    {
        if(t[rt][i])
        {
            if(deep<3)
                str[deep]=i+'0';
            else
                str[3]='-',
                str[deep+1]=i+'0';
            if(vis[t[rt][i]]>=2)
            {
                flag=1;
                str[deep+2]='\0';
                printf("%s %d\n",str,vis[t[rt][i]]);
            }
            dfs(t[rt][i],deep+1);
        }
    }
}
int main()
{
    int n;
    scanf("%d",&n);
    memset(vis,0,sizeof(vis));
    memset(t,0,sizeof(t));
    char ss[222222];
    for(int i=0;i<n;i++)
    {
        scanf("%s",ss),
        insert(ss);
    }
    flag=0;
    dfs(0,0);
    if(!flag)
        printf("No duplicates. \n");
    return 0;
}


法二:全部转化为一个数,用map构成映射,筛选map中数量大于二的元素,并输出

#include<iostream>
#include<string.h>
#include<cstdio>
#include<algorithm>
#include<map>
using namespace std;
/*string ss;
void trans(char s[])
{
    int len=strlen(s);
    ss.clear();
    for(int i=0;i<len;i++)
    {
        if(ss.length()==3)ss+='-';
        if(s[i]=='-') continue;
        else if(s[i]>='0'&&s[i]<='9')
            ss+=s[i];
        else if(s[i]>='A'&&s[i]<'Q')
            ss+=(s[i]-'A')/3+2+'0';
        else if(s[i]>'Q'&&s[i]<'Z')
            ss+=(s[i]-'B')/3+2+'0';
    }
}1800ms,果断改用下面方法*/
int trans(char *ss)
{
    int len=strlen(ss);
    int num=0;
    for(int i=0;i<len;i++)
    {
        if(ss[i]=='-') continue;
        else if(ss[i]>='0'&&ss[i]<='9')
            num=num*10+(ss[i]-'0');
        else if(ss[i]>='A'&&ss[i]<'Q')
            num=num*10+(ss[i]-'A')/3+2;
        else if(ss[i]>'Q'&&ss[i]<'Z')
            num=num*10+(ss[i]-'B')/3+2;
    }
    return num;
}
int main()
{
    int n;
    scanf("%d",&n);
    char s[100];
    map<int,int>m;
    for(int i=0;i<n;i++)
    {
        scanf("%s",s);
        m[trans(s)]++;
    }
    int flag=0;
    map<int,int>::iterator it;
    for(it=m.begin();it!=m.end();it++)
    {
        if(it->second>=2)
           flag=1,//it->first是指mp[key]中的键值(就是key),it->second是指键对应(mp[key])
           printf("%03d-%04d %d\n",it->first/10000,it->first%10000,it->second);
    }
    if(!flag)
      printf("No duplicates.\n");
    return 0;
}

 

posted @ 2018-08-19 16:03  aeipyuan  阅读(196)  评论(0编辑  收藏  举报