A Simple Problem with Integers 区间更新

A Simple Problem with Integers
Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 95298   Accepted: 29682
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

 
和单值更新区别就是pushdown使每段更新完sum后,标记一下。 以后查询时,查看是否标识过,如果表示过,先更新左右子树即可。。
 
#include <cstdio>
#include <algorithm>
#define ll long long
#define maxn 400010
#define lson l,m,rt<<1
#define rson m+1,r,rt<< 1 | 1
using namespace std;
ll sum[maxn],add[maxn];

void PushUp(int rt){
    sum[rt] = sum[rt<<1]+sum[rt<< 1 |1];
}
void build(int l,int r,int rt){
    add[rt]=0;
    if(l==r){
        scanf("%lld",&sum[rt]);
        return;
    }
    int m= (l+r)>>1;
    build(lson);
    build(rson);
    PushUp(rt);
}
void PushDown(int rt,int m){// 向下更新左右子树的和,以及是否被加
    if(add[rt]){
        add[rt<<1]+=add[rt];
        add[rt<<1|1]+=add[rt];
        sum[rt<<1]+=add[rt]*(m-(m>>1));
        sum[rt<<1|1]+=add[rt]*(m>>1);
        add[rt]=0;
    }
}
void update(int L,int R,int c,int l,int r,int rt){  //和区间查询思路差不多。
    if(L<=l&&r<=R){
        sum[rt]+=(ll)c*(r-l+1);
        add[rt]+=c;return;
    }
    PushDown(rt,r-l+1);
    int m=(l+r)>>1;
    if(L<=m) update(L,R,c,lson);
    if(R>m)  update(L,R,c,rson);
    PushUp(rt);
}
ll query(int L,int R,int l,int r,int rt){
    if(r<L||l>R) return 0;
    if(L<=l&&r<=R)return sum[rt];
    PushDown(rt,r-l+1);
    int m = (l+r)>>1;
    ll v1=query(L,R,lson);
    ll v2=query(L,R,rson);
    return v1+v2;
}
int main(){
    //freopen("data.in","r",stdin);
    int n,q;
    scanf("%d%d",&n,&q);
    build(1,n,1);
    while(q--){
        char op[2];
        int a,b,c;
        scanf("%s",op);
        if(op[0]=='Q'){
            scanf("%d%d",&a,&b);
            printf("%lld\n",query(a,b,1,n,1));
        }else{
            scanf("%d%d%d",&a,&b,&c);
            update(a,b,c,1,n,1);
        }
    }
}

 

posted on 2016-08-10 15:54  acmtime  阅读(125)  评论(0编辑  收藏  举报

导航