代码改变世界

semi-join子查询优化 -- FirstMatch策略

2019-05-20 22:30 by abce, 1856 阅读, 0 推荐, 收藏,
摘要:FirstMatch执行semi-join子查询的一种策略。 类似于MySQL 5.x中如何执行in、exists子查询。 让我们以搜索拥有大城市的国家为例: 假设,我们的执行计划是找到欧洲的国家,然后,对于每个找到的国家,检查它是否有大城市。常规的inner join执行将如下所示: 由于德国有两 阅读全文

semi-join子查询优化 -- Duplicate Weedout策略

2019-05-20 17:51 by abce, 1951 阅读, 0 推荐, 收藏,
摘要:duplicate weedout是执行semi-join子查询的一种策略。 将semi-join作为一个常规的inner join。然后使用一个临时表,将重复的记录排除。 假设,你有一个查询,你在寻找一个大城市人口占总人口33%以上的国家: select * from Country where 阅读全文

NBU将RAC数据库恢复到单机

2019-04-17 17:51 by abce, 873 阅读, 0 推荐, 收藏,
摘要:恢复的过程和(https://www.cnblogs.com/abclife/p/5687993.html)差不多。但是,具体过程有些不同。如果按照之前的恢复方式,在run语句中同时运行restore和recover操作,虽然可以执行成功,但是在以resetlogs方式打开时会报错: 从这里可以看到 阅读全文

mycat偶尔会出现JVM报错double free or corruption并崩溃退出

2019-01-08 10:21 by abce, 1355 阅读, 0 推荐, 收藏,
摘要:mycat偶尔会出现JVM报错double free or corruption并崩溃退出 没有复杂的sql,也没有大量的io INFO | jvm 15 | 2019/01/07 18:06:31 | *** Error in `java': double free or corruption ( 阅读全文

exp导出数据时丢表

2018-11-23 12:22 by abce, 1030 阅读, 0 推荐, 收藏,
摘要:友军发来消息,说使用exp导出某个schema的数据的时候,发现有些表没有导出来。因为一直没有使用exp的习惯,就使用exp\expdp再次导出一次,分析二者的日志,发现exp的确有些表没有导出。 问题产生的原因:在11gR2之前,oracle实在表被创建时就分配空间;从11gR2(11.2.0.1 阅读全文

service_names配置不正确,导致dg创建失败

2018-11-14 16:17 by abce, 945 阅读, 0 推荐, 收藏,
摘要:service_names配置不正确,导致dg创建失败 伙伴发来消息,创建dg后,主备一直无法进行日志同步。 以下是查看过程 备库的alert日志: 可以看到在执行alter database recover managed standby database disconnect from sess 阅读全文

12C - PDB archive file

2018-11-06 11:03 by abce, 747 阅读, 0 推荐, 收藏,
摘要:在unplug一个pdb的时候,如果将扩展名定义为.pdb,oracle就会创建一个.pdb归档文件。包含pdb数据文件和xml元数据文件的压缩文件。创建archive file之后,就不用分开拷贝数据文件和xml文件了。 阅读全文

mysql optimize table

2018-09-02 13:54 by abce, 7215 阅读, 0 推荐, 收藏,
摘要:语法结构: optimize table 会重组表数据和索引的物理存储,减少对存储空间使用和提升访问表时io效率。optimize table后,表的变化和存储引擎也有关。 以下场景使用 optimize table,和表的类型有关:1.innodb存储引擎+独立表空间,optimize table 阅读全文

sql中的left join以及on、where关键字的区别

2018-08-30 16:52 by abce, 8255 阅读, 0 推荐, 收藏,
摘要:创建两张表并插入一些数据 查看表中的数据 比较下面几组查询结果--如果你对left join足够熟悉的话,先不要看结果,是否可以直接说出下面查询的结果 如果on后面的条件是左表中的列(and leftTable.colName='***'),左表中满足条件的行和右表中的行进行匹配(根据on left 阅读全文

mysql出现unblock with 'mysqladmin flush-hosts'

2018-08-13 17:24 by abce, 49285 阅读, 2 推荐, 收藏,
摘要:朋友发来消息,说一个系统应用登录的时候提示连接超时,让帮忙处理一下。问他应用和数据库是否都正常,回复说数据库好像没有问题,但是应用日志报无法连接数据库。 数据库版本是:5.5.53 让他telnet数据库是否是通的,回复说不通,并发来了信息提示: 可以看出,产生的原因是: 同一个ip在短时间内产生太 阅读全文
上一页 1 ··· 69 70 71 72 73 74 75 76 77 ··· 124 下一页