代码改变世界

MySQL root授权报错ERROR 1045 (28000)

2021-12-20 23:14 by abce, 2417 阅读, 0 推荐, 收藏,
摘要:创建用户后授权的时候报错,显示没有访问权限: mysql> grant select, process, super, replication client, reload on *.* to 'abc'@'127.0.0.1'; ERROR 1045 (28000): Access denied 阅读全文

PostgreSQL中是否要创建外键索引

2021-12-18 13:56 by abce, 1058 阅读, 0 推荐, 收藏,
摘要:我们常常听说索引可以提升读的性能,通常这也是对的,但是我们也知道这会降低写的性能。我们没有经常听到的是,在有些场景下,索引不会提升任何性能。外键就是个例子。这里不是说所有外键都不好,但我看到的大多场景是不需要外键,有了只是增加系统负载而已。 比如,下面的两张表是1:N的对应关系。 如果我们注意本示例 阅读全文

MySQL从库报Error_code: 2005

2021-12-18 13:49 by abce, 615 阅读, 0 推荐, 收藏,
摘要:创建MySQL主从复制过程中,change master之后,启动slave复制,发现从库状态不正常。报如下错误: mysql> show slave status\G *************************** 1. row *************************** Sl 阅读全文

触发器如何显著影响分配给 MySQL的内存

2021-12-18 12:16 by abce, 600 阅读, 0 推荐, 收藏,
摘要:MySQL使用一个特殊的内存buffer来存放活跃的表描述符,叫做table open cache。这个buffer是通过参数table_open_cache来控制的,table_open_cache定义了MySQL缓存中可以存放的表描述符的最大数量。参数table_open_cache_insta 阅读全文

Oracle中有大量的sniped会话

2021-12-16 20:50 by abce, 924 阅读, 0 推荐, 收藏,
摘要:SQL> select status ,count(*) from gv$session group by status; STATUS COUNT(*) KILLED 2 SNIPED 6365 ACTIVE 373 INACTIVE 3648 SQL> select USERNAME,statu 阅读全文

Oracle kill会话

2021-12-16 20:43 by abce, 948 阅读, 0 推荐, 收藏,
摘要:基本语法是: alter system kill session 'sid,serial#'; 如果是RAC环境,可以指定inst_id: alter system kill session 'sid,serial#,@inst_id'; kill session不会真正killi掉会话。只是告诉会 阅读全文

Error 1130: Host '127.0.0.1' is not allowed to connect to this MySQL server

2021-12-13 19:20 by abce, 833 阅读, 0 推荐, 收藏,
摘要:MySQL客户端连接MySQL Server的时候报错: Connection check failed: Error 1130: Host '127.0.0.1' is not allowed to connect to this MySQL server. 看到网上好多人都是直接将对应的数据库用 阅读全文

MySQL中的timestamp数据类型

2021-11-07 19:41 by abce, 9999 阅读, 0 推荐, 收藏,
摘要:最近看了两篇关于timestamp的文章,正好手头有MySQL5的版本要升级。翻了翻版本5、6、7的文档,做了点笔记。 两篇博客地址: MySQL的TIMESTAMP类型字段非空和默认值属性的影响 MySQL迁移后timestamp列cannot be null date: 日期。有效范围是‘100 阅读全文

Oracle单实例下的service管理

2021-11-07 17:52 by abce, 892 阅读, 0 推荐, 收藏,
摘要:Oracle--单实例下的service管理 1.创建service service_name、network_name两个参数是必须的:前者表示数据字典内部使用的名称;后者是监听中对应的名称。 BEGIN DBMS_SERVICE.create_service( service_name => ' 阅读全文

PIDFile没有配置导致将mongodb配置成服务时启动失败

2021-10-29 19:21 by abce, 692 阅读, 0 推荐, 收藏,
摘要:安装MongoDB,尝试配置成服务后,启动一直不成功 # systemctl start mongod # systemctl status mongod ● mongod.service - High-performance, schema-free document-oriented datab 阅读全文
上一页 1 ··· 49 50 51 52 53 54 55 56 57 ··· 124 下一页