(DP) hdu 5001

Walk

Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 652    Accepted Submission(s): 403
Special Judge


Problem Description
I used to think I could be anything, but now I know that I couldn't do anything. So I started traveling.

The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times.

If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn't contain it.
 

 

Input
The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node a and node b.

T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.
 

 

Output
For each test cases, output n lines, the i-th line containing the desired probability for the i-th node.

Your answer will be accepted if its absolute error doesn't exceed 1e-5.
 

 

Sample Input
2 5 10 100 1 2 2 3 3 4 4 5 1 5 2 4 3 5 2 5 1 4 1 3 10 10 10 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 10 4 9
 

 

Sample Output
0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.6993317967 0.5864284952 0.4440860821 0.2275896991 0.4294074591 0.4851048742 0.4896018842 0.4525044250 0.3406567483 0.6421630037
 

 

Source
 

 

简单DP

考虑到 到不了某点的概率就是到达其他点的概率和。每次都去掉一个点求出到达 其他点的概率就是不能到达这个点的概率。

 

dp[i][j] 表示 到达i位置用了j步

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<vector>
using namespace std;
vector<int> e[1010];
int tt,n,m,d;
double dp[60][10010];
int main()
{
      scanf("%d",&tt);
      while(tt--)
      {
            scanf("%d%d%d",&n,&m,&d);
            for(int i=0;i<=n;i++)
                  e[i].clear();
            for(int i=0;i<m;i++)
            {
                  int x,y;
                  scanf("%d%d",&x,&y);
                  e[x].push_back(y);
                  e[y].push_back(x);
            }
            for(int p=1;p<=n;p++)
            {
                  memset(dp,0,sizeof(dp));
                  for(int i=1;i<=n;i++)
                        dp[i][0]=1.0/n;
                  for(int j=0;j<d;j++)
                  {
                        for(int i=1;i<=n;i++)
                        {
                              if(i==p)
                                    continue;
                              int N=e[i].size();
                              for(int k=0;k<N;k++)
                              {
                                    dp[e[i][k]][j+1]+=dp[i][j]*(1.0)/N;
                              }
                        }
                  }
                  double ans=0;
                  for(int i=1;i<=n;i++)
                  {
                        if(i==p)
                              continue;
                        ans+=dp[i][d];
                  }
                  printf("%.9lf\n",ans);
            }
      }
      return 0;
}

  

 

posted @ 2015-01-26 09:22  心田定则  阅读(114)  评论(0编辑  收藏  举报