(水)hdu 5003

Osu!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 737    Accepted Submission(s): 371
Special Judge


Problem Description
Osu! is a famous music game that attracts a lot of people. In osu!, there is a performance scoring system, which evaluates your performance. Each song you have played will have a score. And the system will sort all you scores in descending order. After that, the i-th song scored ai will add 0.95^(i-1)*ai to your total score.

Now you are given the task to write a calculator for this system.
 

 

Input
The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains an integer n, denoting the number of songs you have played. The second line contains n integers a1, a2, ..., an separated by a single space, denoting the score of each song.

T<=20, n<=50, 1<=ai<=500.
 

 

Output
For each test case, output one line for the answer.

Your answers will be considered correct if its absolute error is smaller than 1e-5.
 

 

Sample Input
1 2 530 478
 

 

Sample Output
984.1000000000
 

 

Source
 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
int tt,n,a[52];
bool cmp(int x,int y)
{
      return x>y;
}
int main()
{
      scanf("%d",&tt);
      while(tt--)
      {
            scanf("%d",&n);
            for(int i=1;i<=n;i++)
                  scanf("%d",&a[i]);
            sort(a+1,a+1+n,cmp);
            double ans=0;
            for(int i=1;i<=n;i++)
                  ans+=pow(0.95,i-1)*a[i];
            printf("%.10lf\n",ans);
      }
      return 0;
}

  

posted @ 2015-01-26 08:53  心田定则  阅读(153)  评论(0编辑  收藏  举报