(Dinic) hdu 3549

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 8864    Accepted Submission(s): 4170


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

 

Sample Input
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

 

Sample Output
Case 1: 1 Case 2: 2
 

 

Author
HyperHexagon
 

 

Source
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<cstdlib>
#include<algorithm>
#include<queue>
using namespace std;
#define INF 0x7fffffff
queue<int> q;
int tab[250][250],dist[250];
int n,m,ans,tt;
int bfs()
{
    int x;
    memset(dist,-1,sizeof(dist));
    dist[1]=0;
    q.push(1);
    while(!q.empty())
    {
        x=q.front(),q.pop();
        for(int i=1;i<=n;i++)
        {
            if(tab[x][i]>0&&dist[i]<0)
            {
                dist[i]=dist[x]+1;
                q.push(i);
            }
        }
    }
    if(dist[n]>0)
        return 1;
    else
    return 0;
}
int find(int x,int low)
{
    int a=0;
    if(x==n) return low;
    for(int i=1;i<=n;i++)
    {
        if(tab[x][i]>0&&dist[i]==dist[x]+1&&(a=find(i,min(low,tab[x][i]))))
        {
            tab[x][i]-=a;
            tab[i][x]+=a;
            return a;
        }
    }
    return 0;
}
int main()
{
    int f,t,flow,tans;
    scanf("%d",&tt);
    while(tt--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&f,&t,&flow);
            tab[f][t]+=flow;
        }
        ans=0;
        while(bfs())
        {
            if(tans=find(1,INF)) ans+=tans;
        }
        printf("%d\n",ans);
    }
    return 0;
}

  

  

posted @ 2015-01-26 00:04  心田定则  阅读(163)  评论(0编辑  收藏  举报