(欧拉函数) SGU 102

A - Coprimes
Time Limit:250MS     Memory Limit:4096KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

 

For given integer N (1<=N<=104) find amount of positive numbers not greater than N that coprime with N. Let us call two positive integers (say, A and B, for example) coprime if (and only if) their greatest common divisor is 1. (i.e. A and B are coprime iff gcd(A,B) = 1).

 

Input

Input file contains integer N.

 

Output

Write answer in output file.

 

Sample Input

9

Sample Output

6
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int n;
int main()
{
      scanf("%d",&n);
      int m=n;
      for(int p=2;n!=1;p++)
      {
            if(n%p==0)
                  m=m-m/p;
            while(n%p==0)
                  n=n/p;
      }
      printf("%d\n",m);
      return 0;
}

  

posted @ 2015-01-20 12:36  心田定则  阅读(124)  评论(0编辑  收藏  举报