Description

Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go. 

Here is the rules for ancient go they were playing: 

The game is played on a  cell board, the chess can be put on the intersection of the board lines, so there are  different positions to put the chess. 
Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately. 
The chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, this component dies and will be removed from the game board. 
When one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove the dead components. 
One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu's chess.

Input

The first line of the input gives the number of test cases,  test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board.  represents an empty cell.  represents a cell with black chess which owned by Yu Zhou.  represents a cell with white chess which owned by Su Lu.

Output

For each test case, output one line containing Case #x: y, where  is the test case number (starting from 1) and  is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu's components. Can not kill in one move!!! otherwise.

Sample Input

2

.......xo
.........
.........
..x......
.xox....x
.o.o...xo
..o......
.....xxxo
....xooo.

......ox.
.......o.
...o.....
..o.o....
...o.....
.........
.......o.
...x.....
........o

Sample Output

Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!
提交时 感觉自己代码已经差不多了 最后 还是提取重复了
这个 是不可以的    但是我的代码还是可以    然后 用了一个数组标记   就搞定了
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<math.h>
using namespace std;
#define LL long long
#define INF 0x3f3f3f3f
#define N 20
char str[N][N];
int s,w[N][N],ww[N][N];
int a[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
void q(int x,int y)
{
    for(int i=0;i<4;i++)
    {
        int e=x+a[i][0];
        int f=y+a[i][1];
        if(e<0||e>=9||f<0||f>=9) continue;
        if(str[e][f]=='.'&&!ww[e][f])///看看这个区域里面有多少个‘.’  要避免重复就用ww标记
        {
            ww[e][f]=1;
            s++;
        }
        if(str[e][f]=='o'&&!w[e][f])///区域增加
        {
            w[e][f]=1;
            q(e,f);
        }

    }
}
int main()
{
    int T,n=9,t=1;
    scanf("%d",&T);
    while(T--)
    {
        for(int i=0;i<n;i++)
            scanf("%s",str[i]);
        memset(w,0,sizeof(w));
        int ans=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(str[i][j]=='o'&&!w[i][j])///如果满足 就开始查找
                {
                    s=0;
                    w[i][j]=1;
                    memset(ww,0,sizeof(ww));
                    q(i,j);
                    if(s<=1)///如果满足 就可以封死  
                    {
                        ans=1;
                        break;
                    }
                }
            }
        }
        if(ans) printf("Case #%d: Can kill in one move!!!\n",t++);
        else
            printf("Case #%d: Can not kill in one move!!!\n",t++);
    }
    return 0;
}

 

 


 

posted on 2016-08-23 16:53  云胡不喜。  阅读(274)  评论(0编辑  收藏  举报