Problem Description
The story happened long long ago. One day, Cao Cao made a special order called "Chicken Rib" to his army. No one got his point and all became very panic. However, Cao Cao himself felt very proud of his interesting idea and enjoyed it.

Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he's clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang.

He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container.

Formally, we can treat the container stick as an L length segment. And the gold sticks as segments too. There were many gold sticks with different length ai and value vi. Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks.

As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks Xiu Yang made it in the container.

Can you help solve the mystery by finding out what's the maximum value of the gold sticks Xiu Yang could have taken?
 

 

Input
The first line of the input gives the number of test cases, T(1T100)T test cases follow. Each test case start with two integers, N(1N1000) and L(1L2000), represents the number of gold sticks and the length of the container stick. N lines follow. Each line consist of two integers, ai(1ai2000)and vi(1vi109), represents the length and the value of the ith gold stick.
 

 

Output
For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is the maximum value of the gold sticks Xiu Yang could have taken.
 

 

Sample Input
4
3 7
4 1 2 1 8 1
3 7
4 2 2 1 8 4
3 5
4 1 2 2 8 9
1 1
10 3
 

 

Sample Output
Case #1: 2
Case #2: 6
Case #3: 11
Case #4: 3
在这里面的k记录了有几个   因为有两端 可以有两个的一半进入
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<math.h>
using namespace std;
#define LL long long
#define INF 0x3f3f3f3f
#define N 4006
int q[N],a[N];
LL dp[N][4];
int main()
{
    int T,n,m,t=1;
    scanf("%d",&T);
    while(T--)
    {
        memset(dp,0,sizeof(dp));
        scanf("%d%d",&n,&m);
        m=m*2;///扩大一倍  满足那个存入一半的
        LL ans=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&a[i],&q[i]);
            a[i]=a[i]*2;///同理
            ans=max(ans,(LL)q[i]);///主要是为了判断n为1的时候  
        }
        for(int i=0;i<n;i++)
        {
            for(int j=m;j>=a[i]/2;j--)
            {
                for(int k=0;k<3;k++)///k只要是是表达用了几次端点   因为就2个端点 故k<3
                {
                    if(j>=a[i]) dp[j][k]=max(dp[j][k],dp[j-a[i]][k]+q[i]);
                    if(k>0)///k=0表示没有在端点处  k>0表示在端点
                        dp[j][k]=max(dp[j][k],dp[j-a[i]/2][k-1]+q[i]);///这一个端点值   等于上一个即k-1加上价值
                    ans=max(ans,dp[j][k]);///不断更新
                }
            }
        }
        printf("Case #%d: %lld\n",t++,ans);
    }
    return 0;
}

表示 自己写的一般般   

posted on 2016-08-23 16:23  云胡不喜。  阅读(270)  评论(0编辑  收藏  举报