POJ 3259 Wormholes( bellmanFord判负环)

Wormholes
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 36425   Accepted: 13320

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

题意:判断是否有负环。
收获:bellmanFord:松弛n-1轮,每次把所有边都用上,如果还存在 dis[edge[j].v] > dis[edge[j].u] + edge[j].w 则有负环。
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <list>
#include <vector>
#include <map>
#include <set>
using namespace std;

const int INF=0x3f3f3f3f;
const double eps=1e-10;
const double PI=acos(-1.0);

const int maxn=5000+100;
int n;
struct Edge
{
    int u, v, w, next;
};
Edge edge[maxn];
int num;
int head[maxn];
void init_edge()
{
    num = 0;
    memset(head, -1, sizeof(head));
}
void addedge(int u, int v, int w)
{
    edge[num].u = u;
    edge[num].v = v;
    edge[num].w = w;
    edge[num].next = head[u];
    head[u] = num++;
}
int dis[maxn];
bool bellmanFord()//bellmanFord模板
{
    for(int i = 1; i <= n; i++) dis[i] = INF;
    dis[1] = 0;
    for(int i = 0; i < n; i++)
    {
        for(int j = 0; j < num; j++)
        {
            if(dis[edge[j].v] > dis[edge[j].u] + edge[j].w)
                dis[edge[j].v] = dis[edge[j].u] + edge[j].w;
        }
    }
    //bool flag = 1;
    for(int j = 0; j < num; j++)
    {
        if(dis[edge[j].v] > dis[edge[j].u] + edge[j].w)
        return 0;
    }
    return 1;
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int m ,w;
        scanf("%d%d%d",&n, &m, &w);
        int a, b, c;
        init_edge();
        for(int i = 0; i < m; i++)
        {
            scanf("%d%d%d", &a, &b,&c);
            addedge(a, b, c);
            addedge(b, a, c);
        }
        for(int i = 0; i < w; i++)
        {
            scanf("%d%d%d", &a, &b,&c);
            addedge(a, b, -c);
        }
        //int flag = 0;
        if(!bellmanFord())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

 

posted @ 2015-08-09 10:43  JoneZP  阅读(223)  评论(0编辑  收藏  举报