hdu 2516 取石子游戏 (斐波那契博弈)

取石子游戏

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
http://acm.hdu.edu.cn/showproblem.php?pid=2516

Problem Description
1堆石子有n个,两人轮流取.先取者第1次可以取任意多个,但不能全部取完.以后每次取的石子数不能超过上次取子数的2倍。取完者胜.先取者负输出"Second win".先取者胜输出"First win".
 
Input
输入有多组.每组第1行是2<=n<2^31. n=0退出.
 
Output
先取者负输出"Second win". 先取者胜输出"First win".
参看Sample Output.
 
Sample Input
2 13 10000 0
 
Sample Output
Second win
Second win
First win
 
结论:
若n=斐波那契数,则先手必败,否则先手必胜。
#include<cstdio>
#include<algorithm>
using namespace std;
const long long a=(1<<31)-1;
long long f[50];
int main()
{
    f[1]=1;f[2]=2;
    int i=2;
    while(f[i]<a) f[++i]=f[i-1]+f[i-2];
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(!n) return 0;
        if(f[lower_bound(f+1,f+i+1,n)-f]==n)   printf("Second win\n");
        else printf("First win\n");
    }
}

 

 
posted @ 2017-04-21 16:57  TRTTG  阅读(234)  评论(0编辑  收藏  举报