上一页 1 2 3 4 5 6 ··· 10 下一页
摘要: 前段时间做项目,遇到一个问题,用yii2的AR连表查询数据的时候,理应该查出来更多的数据,但是实际得到的只有部分数据: 例如,有这么一个查询: 这里的连表中主表个字表的关系是一对多,打出的,写成原生sql: 原生sql查到的结果: 但是AR查到的结果(只有13条): 自己观察下数据,就发现,将sql 阅读全文
posted @ 2018-01-09 13:01 Steven* 阅读(521) 评论(0) 推荐(0) 编辑
摘要: 昨天在nginx上部署了一个网站后,发现访问不了,再去访问之前部署的网站,发现都访问不了了,去看下下nginx,发现nginx服务停止了,没有在运行,重启了下服务,发现还是一样,就去看了下nginx的日志,发下下面这样的提示: 看到什么server_names_hash_bucket_size之类的 阅读全文
posted @ 2018-01-08 09:37 Steven* 阅读(2769) 评论(0) 推荐(0) 编辑
摘要: 首先,PhpStorm中文件、类、函数等注释的设置在:setting-》Editor-》FIle and Code Template-》Includes下设置即可,其中方法的默认是这样的: 但是我发现,文件中的默认注释是这样的: 当我把上面这段中3、4、5行的代码直接复制放到PHP Function 阅读全文
posted @ 2017-12-28 15:48 Steven* 阅读(30213) 评论(5) 推荐(0) 编辑
摘要: 在使用attr给元素设置属性的时候,但是显示在页面就是未选中,而且是只使用一两次是ok的,但是连着多使用就不起作用了,百度了下,发现遇到这个问题的人还蛮多的, 有人说,发现在jQuery1.6版本之后,用prop 替换了attr,替换了测试了下,果然OK,但是详细查询了下资料,发现这种说法并不准确 阅读全文
posted @ 2017-12-21 18:21 Steven* 阅读(1897) 评论(0) 推荐(0) 编辑
摘要: 今天在写一个网页的时候发现一个问题,我的table的样式很奇怪,也没有设置什么样式,跟其他的页面不一样,打开开发者工具一看,发现有这么点样式: 其中右上角:user agent stylesheet 1、user agent stylesheet是浏览器默认样式表,在写网页时,没有指定的样式,按浏览 阅读全文
posted @ 2017-12-01 11:58 Steven* 阅读(833) 评论(0) 推荐(0) 编辑
摘要: 例如: 当然,用循环遍历是可以解决的,但是还是觉得效率有点低,这里有另外一个解决方案,是使用两个PHP提供的函数: 附: 1、array_column 参考我之前的博客 http://www.cnblogs.com/Steven-shi/p/5897745.html 2、array_multisor 阅读全文
posted @ 2017-11-20 11:18 Steven* 阅读(7871) 评论(0) 推荐(1) 编辑
摘要: yii2在使用的时候,访问控制器的时候,如果控制器的名称是驼峰命名法,那访问的url中要改成横线的形式。例如: 最近在做某渠道的直连的时候,他们提供的文档上明确指出接口的形式: 刚开始以为YII2中肯定有这样的设置,然后就去google了下,发现都说不行,自己去看了下,果然,框架里面直接是写死的:( 阅读全文
posted @ 2017-10-30 09:56 Steven* 阅读(3415) 评论(1) 推荐(1) 编辑
摘要: 起因:由于需要,要把一张表的一个字段从不是 null 改成 可null,我用的Navicat Premium ,但是在保存的时候,工具无响应了,几个同事操作都是这样的,很奇怪,怀疑是不是由于表被锁了还是什么原因 去数据库看下: 发现有一个线程很奇怪:这个进程的State是Waiting for ta 阅读全文
posted @ 2017-10-11 17:51 Steven* 阅读(1507) 评论(0) 推荐(1) 编辑
摘要: 转载自:http://www.ruanyifeng.com/blog/2013/04/processes_and_threads.html 进程(process)和线程(thread)是操作系统的基本概念,但是它们比较抽象,不容易掌握。 最近,我读到一篇材料,发现有一个很好的类比,可以把它们解释地清 阅读全文
posted @ 2017-10-11 14:30 Steven* 阅读(149) 评论(0) 推荐(0) 编辑
摘要: 每天早晨打开电脑运行本地项目的时候,有时候浏览器上会出现EOF 之前都都能正常访问,所以我猜想本地的项目本身肯定是没有问题的。 Google了下,发现有人说是代理的问题,于是关闭代理试过后,发现可以访问了 解决方法: 1.关掉代理软件 2.给你本地的项目更换域名,重新绑定host即可 也有人反馈wi 阅读全文
posted @ 2017-10-09 13:48 Steven* 阅读(450) 评论(0) 推荐(0) 编辑
上一页 1 2 3 4 5 6 ··· 10 下一页