POJ 3259 Wormholes(最短路径,求负环)

POJ 3259 Wormholes(最短路径,求负环)

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself 😃 .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Http

POJ:https://vjudge.net/problem/POJ-3259

Source

最短路径,求负环

题目大意

给出若干双向道路和单向虫洞,虫洞可以回复时间(即边权为负),而正常的双向道路需要花费一定的时间,现在求能否通过虫洞求得一个负环

解决思路

运用spfa算法,对每一个点做一个统计,统计入队的次数,如果发现次数>=点数,则说明有负环

代码

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;

const int maxN=600;
const int inf=2147483647;

class Edge
{
public:
    int v,w;
};

int n,m,m2;
vector<Edge> E[maxN];
bool inqueue[maxN];
queue<int> Q;
int Dist[maxN];
int Tot[maxN];

int main()
{
    int T;
    while (cin>>T)
    {
    for (int ti=1;ti<=T;ti++)
    {
        scanf("%d%d%d",&n,&m,&m2);
        for (int i=1;i<=n;i++)
        {
            Dist[i]=inf;
            E[i].clear();
        }
        for (int i=1;i<=m;i++)
        {
            int u,w,v;
            scanf("%d%d%d",&u,&v,&w);
            E[u].push_back((Edge){v,w});
            E[v].push_back((Edge){u,w});
        }
        for (int i=1;i<=m2;i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            E[u].push_back((Edge){v,-w});
        }
        memset(inqueue,0,sizeof(inqueue));
        memset(Tot,0,sizeof(Tot));
        while (!Q.empty())
            Q.pop();
        Dist[1]=0;
        Q.push(1);
        inqueue[1]=1;
        bool get=0;
        do
        {
            int u=Q.front();
            Q.pop();
            inqueue[u]=0;
            Tot[u]++;
            if (Tot[u]>=n)
            {
                get=1;
                break;
            }
            for (int i=0;i<E[u].size();i++)
            {
                int v=E[u][i].v;
                int w=E[u][i].w;
                if (Dist[v]>Dist[u]+w)
                {
                    Dist[v]=Dist[u]+w;
                    if (inqueue[v]==0)
                    {
                        Q.push(v);
                        inqueue[v]=1;
                    }
                }
            }
        }
        while (!Q.empty());
        if (get)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    }
    return 0;
}
posted @ 2017-07-23 22:34  SYCstudio  阅读(240)  评论(0编辑  收藏  举报