UVA 1025 A Spy in the Metro 【DAG上DP/逆推/三维标记数组+二维状态数组】

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After
several thrilling events we find her in the first station of Algorithms City Metro, examining the time
table. The Algorithms City Metro consists of a single line with trains running both ways, so its time
table is not complicated.
Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria
knows that a powerful organization is after her. She also knows that while waiting at a station, she is
at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running
trains as much as possible, even if this means traveling backward and forward. Maria needs to know
a schedule with minimal waiting time at the stations that gets her to the last station in time for her
appointment. You must write a program that finds the total waiting time in a best schedule for Maria.
The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains
move in both directions: from the first station to the last station and from the last station back to the
first station. The time required for a train to travel between two consecutive stations is fixed since all
trains move at the same speed. Trains make a very short stop at each station, which you can ignore
for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the
trains involved stop in that station at the same time.
Input
The input file contains several test cases. Each test case consists of seven lines with information as
follows.
Line 1. The integer N (2 ≤ N ≤ 50), which is the number of stations.
Line 2. The integer T (0 ≤ T ≤ 200), which is the time of the appointment.
Line 3. N − 1 integers: t1, t2, . . . , tN−1 (1 ≤ ti ≤ 20), representing the travel times for the trains
between two consecutive stations: t1 represents the travel time between the first two stations, t2
the time between the second and the third station, and so on.
Line 4. The integer M1 (1 ≤ M1 ≤ 50), representing the number of trains departing from the first
station.
Line 5. M1 integers: d1, d2, . . . , dM1 (0 ≤ di ≤ 250 and di < di+1), representing the times at which
trains depart from the first station.
Line 6. The integer M2 (1 ≤ M2 ≤ 50), representing the number of trains departing from the N-th
station.
Line 7. M2 integers: e1, e2, . . . , eM2 (0 ≤ ei ≤ 250 and ei < ei+1) representing the times at which
trains depart from the N-th station.
The last case is followed by a line containing a single zero.
Output
For each test case, print a line containing the case number (starting with 1) and an integer representing
the total waiting time in the stations for a best schedule, or the word ‘impossible’ in case Maria is
unable to make the appointment. Use the format of the sample output.
Sample Input
4
55
5 10 15
4
0 5 10 20
4
0 5 10 15
4
18
1 2 3
5
0 3 6 10 12
6
0 3 5 7 12 15
2
30
20
1
20
7
1 3 5 7 11 13 17
0
Sample Output
Case Number 1: 5
Case Number 2: 0
Case Number 3: impossible
#include<bits/stdc++.h>

using namespace std;
const int INF = 1e6;
int n,m,T;
int t[60];
int d[260][60];
int ok[260][60][2];
int main()
{
    int kase=0;
    while(cin>>n,n)
    {
        cin>>T;
        for(int i=1;i<n;i++) cin>>t[i];

        int M1;
        cin>>M1;
        memset(ok,0,sizeof(ok));
        for(int i=1;i<=M1;i++)
        {
            int Tm,j=1;
            cin>>Tm;
            while(Tm<=T && j<n)
            {
                ok[Tm][j][0]=1;
                Tm+=t[j++];
            }
        }
        int M2;
        cin>>M2;
        for(int i=1;i<=M2;i++)
        {
            int Tm,j=n;
            cin>>Tm;
            while(Tm<=T && j>1)
            {
                ok[Tm][j][1]=1;
                Tm+=t[--j];
            }
        }

        for(int i=1;i<n;i++) d[T][i]=INF;
        d[T][n]=0;

        for(int i=T-1; i>=0; i--)
        {
            for(int j=1; j<=n; j++)
            {
                d[i][j] = d[i+1][j] + 1;
                if(j<n && ok[i][j][0] && i+t[j]<=T)
                    d[i][j]=min(d[i][j],d[i+t[j]][j+1]);
                if(j>1 && ok[i][j][1] && i+t[j-1]<=T)
                    d[i][j]=min(d[i][j],d[i+t[j-1]][j-1]);
            }
        }

        printf("Case Number %d: ", ++kase);
        if(d[0][1] > INF) printf("impossible\n");
        else printf("%d\n", d[0][1]);
    }
}
posted @ 2018-05-08 23:37  Roni_i  阅读(147)  评论(0编辑  收藏  举报