Floyd算法C++实现与模板题应用

简介

Floyd算法算是最简单的算法,没有之一。

其状态转移方程如下map[i , j] =min{ map[i , k] + map[k , j] , map[i , j] };
map[i , j]表示 i 到 j 的最短距离,K是穷举 i , j 的断点,map[n , n]初值应该为0,或者按照题目意思来做。
当然,如果这条路没有通的话,还必须特殊处理,比如没有map[i , k]这条路。

算法步骤
1,从任意一条单边路径开始。所有两点之间的距离是边的权,如果两点之间没有边相连,则权为无穷大。
2,对于每一对顶点 u 和 v,看看是否存在一个顶点 w 使得从 u 到 w 再到 v 比已知的路径更短。如果是更新它。
把图用邻接矩阵G表示出来,如果从Vi到Vj有路可达,则G[i,j]=d,d表示该路的长度;否则G[i,j]=无穷大。定义一个矩阵D用来记录
所插入点的信息,D[i,j]表示从Vi到Vj需要经过的点,初始化D[i,j]=j。把各个顶点插入图中,比较插点后的距离与原来的距离,
G[i,j] = min( G[i,j], G[i,k]+G[k,j] ),如果G[i,j]的值变小,则D[i,j]=k。在G中包含有两点之间最短道路的信息,而在D中则包含了最短通路径的信息。

具体参考这篇文章

https://www.cnblogs.com/wangyuliang/p/9216365.html

C++实现

#include<iostream>
using namespace std;

const int inf = 0x7fffff - 1;
int e[10][10];
int n, m;


int main() {
	cin >> n >> m;
	for (int i = 0; i < n; i++) {
		for (int j = 0; j < n; j++) {
			if (i == j)e[i][j] = 0;
			else e[i][j] = inf;
		}
	}
	int src, dst, val;
	for (int i = 0; i < m; i++) {
		cin >> src >> dst >> val;
		e[src][dst] = val;
	}

	//Floyd-Warshall算法核心语句
	for (int k = 0; k < n; k++) {
		for (int i = 0; i < n; i++) {
			for (int j = 0; j < n; j++) {
				if (e[i][k] + e[k][j] < e[i][j]) {
					e[i][j] = e[i][k] + e[k][j];
				}
			}
		}
	}

	for (int i = 0; i < n; i++) {
		for (int j = 0; j < n; j++) {
			printf("%5d", e[i][j]);
		}
		cout << endl;
	}

	return 0;
}

/*
4 8
0 1 2
0 2 6
0 3 4
1 2 3
2 0 7
2 3 1
3 0 5
3 2 12
 */

百练-Stockbroker Grapevine

  • 总时间限制:

    1000ms

  • 内存限制:

    65536kB

  • 描述

    Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.Unfortunately for you, stockbrokers only trust information coming from their “Trusted sources” This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

  • 输入

    Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a ‘1’ means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

  • 输出

    For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message “disjoint”. Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

  • 样例输入

    3
    2 2 4 3 5
    2 1 2 3 6
    2 1 2 2 2
    5
    3 4 4 2 8 5 3
    1 5 8
    4 1 6 4 10 2 7 5 2
    0
    2 2 5 1 5
    0
    
  • 样例输出

    3 2
    3 10
    

C++实现

#include<iostream>
#include<vector>
using namespace std;
const int inf = 0x7ffffff;
int e[101][101];
int main() {
	int n;
	while (cin >> n) {
		if (n == 0)break;
		int ans = 0, pos = 0;
		fill(e[0], e[0] + 100 * 100, inf);
		for (int i = 0; i <= 100; i++) {
			e[i][i] = 0;
		}
		int dst, val;
		for (int i = 1; i <= n; i++) { //录入数字,作为初始化
			int num;
			cin >> num;
			for (int j = 0; j < num; j++) {
				cin >> dst >> val;
				e[i][dst] = val;
			}
		}
		for (int k = 1; k <= n; k++) {
			for (int i = 1; i <= n; i++) {
				for (int j = 1; j <= n; j++) {
					if (e[i][k] + e[k][j] < e[i][j]) {
						e[i][j] = e[i][k] + e[k][j];
					}
				}
			}
		}
		int minn = inf;
		for (int i = 1; i <= n; i++) {
			ans = 0;
			for (int j = 1; j <= n; j++) {
				ans = ans > e[i][j] ? ans : e[i][j];
			}
			if (ans < minn) {
				minn = ans;
				pos = i;
			}
		}
		cout << pos << " " << minn << endl;
	}
	return 0;
}
posted @ 2020-05-19 17:39  Koshkaaa  阅读(516)  评论(0编辑  收藏  举报