九度OJ-1042-最长公共子序列(LCS)

题目1042:Coincidence

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:4045

解决:2208

题目描述:

Find a longest common subsequence of two strings.

输入:

First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.

输出:

For each case, output k – the length of a longest common subsequence in one line.

样例输入:
abcd
cxbydz
样例输出:
2
来源:
2008年上海交通大学计算机研究生机试真题
#include <stdio.h>
#include <string.h>

int max(int a, int b)    {
    return a>b ? a:b; 
} 

int dp[101][101];

int main()    {
    char a[101];
    char b[101];
    while(scanf("%s%s", a, b) != EOF)    {
        int la = strlen(a);
        int lb = strlen(b);
        for(int i = 0; i <= la; i++)    dp[i][0] = 0;
        for(int j = 0; j <= lb; j++)    dp[0][j] = 0;
        
        for(int i = 1; i <= la; i++)    {
            for(int j = 1; j <= lb; j++)    {
                if(a[i-1] == b[j-1])    {
                    dp[i][j] = dp[i-1][j-1] + 1;
                }
                else if (a[i-1] != b[j-1])    {
                    dp[i][j] = max(dp[i][j-1], dp[i-1][j]);
                }
                // printf("%d ", dp[i][j]);
            }
            // printf("\n");
        }
        // printf("%d %d\n", la, lb);
        printf("%d\n", dp[la][lb]);
    }
    return 0;
}

还是动态规划的思想,从逻辑层构建好,下一个建立在上一个基础上

 

posted on 2017-06-30 19:00  Oliver-cs  阅读(369)  评论(0编辑  收藏  举报

导航