HNUSTOJ-1253 Babelfish(字典树)

 

1253: Problem C: Babelfish

时间限制: 1 Sec  内存限制: 128 MB
提交: 14  解决: 3
[提交][状态][讨论版]

题目描述

 

Problem C: Babelfish

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters. Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

输入

 

输出

 

样例输入

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

样例输出

cat
eh
loops
#include<iostream>
#include<cstring>
#include<cstdio>
 
using namespace std;
const int N = 110000 + 5;
 
struct node{
    int v;
    struct node *next[26];
}*T;
 
node *newnode(){
     node *p = new node;
     for(int i = 0; i < 26; i++) p -> next[i] = NULL;
     return p;
}
 
void Insert(node *p, char *str, int v){
    int c, len = strlen(str);
    for(int i = 0; i < len; i++){
        if(!islower(str[i])) continue;
        c = str[i] - 'a';
        if(p -> next[c] == NULL) p -> next[c] = newnode();
        p = p -> next[c];
    }
    p -> v = v;
}
 
int Query(node *p, char *str){
    int c, len = strlen(str);
    for(int i = 0; i < len; i++){
        if(!islower(str[i])) continue;
        c = str[i] - 'a';
        if(p -> next[c] == NULL) return 0;
        p = p -> next[c];
    }
    return p -> v;
}
char dic[N][15], str[30];
int main(){
    int cur = 0;
    T = newnode();
    while( ++cur ){
        fgets(str, 30, stdin);
        if(isspace(str[0])) break;
        sscanf(str, "%s %s", dic[cur], str);
        Insert(T, str, cur);
    }
    while(fgets(str, 30, stdin) != NULL){
        if(isspace(str[0])) break;
        cur = Query(T, str);
        printf("%s\n", cur? dic[cur]: "eh");
    }
}

 

 
posted @ 2017-08-21 21:29  Pretty9  阅读(193)  评论(0编辑  收藏  举报