搜索专题: HDU1312Red and Black

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20799    Accepted Submission(s): 12664


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
45 59 6 13
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:  1253 1240 1072 1181 1175 
就是求包括'@'在内的一个连同块里有几个方块就OK了,DFS;
代码如下:
Problem : 1312 ( Red and Black )     Judge Status : Accepted
RunId : 21281946    Language : G++    Author : hnustwanghe
Code Render Status : Rendered By HDOJ G++ Code Render Version 0.01 Beta
#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;
const int N = 20 + 5;
char mat[N][N];
bool visit[N][N];
int n,m;
const int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};

void DFS(int x,int y){
    if(x<0 || x>=n || y<0 || y>=m || visit[x][y] || mat[x][y]!='.') return ;
    visit[x][y] = true;
    for(int d=0;d<4;d++){
        int newx = x + dir[d][0];
        int newy = y + dir[d][1];
        DFS(newx,newy);
    }
}
int main(){
    while(scanf("%d %d",&m,&n)==2 && (n||m)){
        int x=0,y=0;
        for(int i=0;i<n;i++){
            scanf("%s",mat[i]);
            for(int j=0;j<m;j++)
                if(mat[i][j]=='@')
                 x = i,y = j;
        }
        memset(visit,0,sizeof(visit));
        mat[x][y]='.';
        DFS(x,y);
        int cnt=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            if(mat[i][j]=='.' && visit[i][j])
                cnt++;
        printf("%d\n",cnt);
    }
}



 
posted @ 2017-07-25 20:53  Pretty9  阅读(97)  评论(0编辑  收藏  举报