HDU-1075 What Are You Talking About 字典树

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 4050    Accepted Submission(s): 1171


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 

Sample Output
hello, i'm from mars. i like earth!
Hint
Huge input, scanf is recommended.
 

题目就是要求你做一个简单的翻译器,告诉你火星文,翻译出英文。

代码如下:

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <time.h>
#include <conio.h>

typedef struct Trie
{
    int flag;
    Trie *child[26];
    char *translation;
} root, node;

root *init(  )
{
    root *r= ( root * )malloc( sizeof( root ) );
    r->flag= 0;
    memset( r-> child, 0, sizeof( r-> child ) );
    return r;
}

void insert( node *parent, char *in, char *trans )
{
    if( *in== '\0' )
    {
        parent-> flag= 1;
        parent-> translation= trans;
        return;
    } 
    if( !parent-> child[ *in- 'a' ] )
        parent-> child[ *in- 'a' ]= init(  ); 
        
    insert( parent-> child[ *in- 'a' ], in+ 1, trans );
}

bool search( node *parent, char *in )
{
    if( *in== '\0' )
    {
        if( parent-> flag== 1 )
        {
            printf( "%s", parent-> translation );
            return true;
        }
        else 
            return false;
    }
    if( !parent-> child[ *in- 'a' ] ) 
        return false; 
    else 
        search( parent-> child[ *in- 'a' ], in+ 1 ); 
}

bool legal( char chr )
{
    if( chr>= 'a'&& chr<= 'z' )
        return true;
    else
        return false;
}

int main()
{
    char en[12], mar[12], words[3005];
    scanf( "%s", en );
    root *r= init(  );
    while( scanf( "%s", en ), strcmp( en, "END" ) )
    {
        char *trans= ( char * )malloc( sizeof( en ) );
        strcpy( trans, en );
        scanf( "%s", mar );
        insert( r, mar, trans );
    }
    scanf( "%s%*", en );
    char c, temp[12];
    int cnt= 0;
    while( c= getchar(  ) )
    {
        if( ( c< 'a'|| c> 'z' )&&( c< 'A'|| c> 'Z' ) )
        {
            temp[cnt]= '\0';
            if( !strcmp( temp, "END" ) )
                break;
            if( !search( r, temp ) )
                printf( "%s", temp );
            printf( "%c", c );
            cnt= 0;
        }
        else 
        {
            temp[cnt++]= c;
        }
    }
    return 0;
}

  今天晚上头太晕了,敲这个程序敲了三个小时左右,晕啊。。。。。
posted @ 2011-05-30 22:39  沐阳  阅读(759)  评论(0编辑  收藏  举报