centos7安装bower遇到的问题

Bower依赖node, npm和git。

安装nodejs遇到

Error: Package: 1:nodejs-6.11.1-1.el7.x86_64 (epel)
           Requires: libhttp_parser.so.2()(64bit)
Error: Package: 1:nodejs-6.11.1-1.el7.x86_64 (epel)
           Requires: http-parser >= 2.7.0

这是因为该包从EPEL中删除了,因为http-parser现在包含在RHEL 7.4中,而EPEL不提供在RHEL中的包。所以需要安装第三方http-parser软件包
 sudo rpm -ivh https://kojipkgs.fedoraproject.org//packages/http-parser/2.7.1/3.el7/x86_64/http-parser-2.7.1-3.el7.x86_64.rpm

安装完第三方http-parser之后就可以正常安装nodejs(# sudo yum install nodejs),进而安装bower.



posted @ 2017-08-23 16:23  Hello_2018  阅读(1674)  评论(0编辑  收藏