随笔- 53  评论- 213  文章- 14 

身份证校验规则

变量1 = 到整数 (编辑框1.内容)
变量2 = 到整数 (编辑框2.内容)
变量3 = 到整数 (编辑框3.内容)
变量4 = 到整数 (编辑框4.内容)
变量5 = 到整数 (编辑框5.内容)
变量6 = 到整数 (编辑框6.内容)
变量7 = 到整数 (编辑框7.内容)
变量8 = 到整数 (编辑框8.内容)
变量9 = 到整数 (编辑框9.内容)
变量10 = 到整数 (编辑框10.内容)
变量11 = 到整数 (编辑框11.内容)
变量12 = 到整数 (编辑框12.内容)
变量13 = 到整数 (编辑框13.内容)
变量14 = 到整数 (编辑框14.内容)
变量15 = 到整数 (编辑框15.内容)
变量16 = 到整数 (编辑框16.内容)
变量17 = 到整数 (编辑框17.内容)
变量18 = 到整数 (编辑框18.内容)
变量100 = 变量1 × 7 + 变量2 × 9 + 变量3 × 10 + 变量4 × 5 + 变量5 × 8 + 变量6 × 4 + 变量7 × 2 + 变量8 × 1 + 变量9 × 6 + 变量10 × 3 + 变量11 × 7 + 变量12 × 9 + 变量13 × 10 + 变量14 × 5 + 变量15 × 8 + 变量16 × 4 + 变量17 × 2
变量 = 变量100 % 11
.如果真 (变量 = 0)
    校验码 = 1
.如果真结束

.如果真 (变量 = 1)
    校验码 = 0
.如果真结束

.如果真 (变量 = 2)
    校验码 = 10
.如果真结束

.如果真 (变量 = 3)
    校验码 = 9
.如果真结束

.如果真 (变量 = 4)
    校验码 = 8
.如果真结束

.如果真 (变量 = 5)
    校验码 = 7
.如果真结束

.如果真 (变量 = 6)
    校验码 = 6
.如果真结束

.如果真 (变量 = 7)
    校验码 = 5
.如果真结束

.如果真 (变量 = 8)
    校验码 = 4
.如果真结束

.如果真 (变量 = 9)
    校验码 = 3
.如果真结束

.如果真 (变量 = 10)
    校验码 = 2
.如果真结束


.如果 (校验码 = 变量18)
    信息框 (“地球上确实存在这个身份证号码”, 0, )
.否则
    信息框 (“地球上不存在这个身份证号码,您是从外星来的吧”, 0, )

.如果结束

posted on 2013-08-21 08:37  懒蜜蜂  阅读(1413)  评论(0编辑  收藏