HDU 1711 Number Sequence

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 

 

Sample Output
6
-1
 
裸KMP算法,也是我第一道KMP算法题
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
#define inf 0xffffff
#define maxn 1000005
#define maxm 10005

int M,N;
int S[maxn],T[maxm];

void get_next(int T[],int *next)
{
    next[0] = -1;
    int i = 0,j = -1;
    while(i < M){
        if(j == -1 || T[i] == T[j]){
            ++i,++j;
            if(T[i] != T[j]) next[i] = j;
            else next[i] = next[j];
        }
        else j = next[j];
    }
}

int KMP(int S[],int T[])
{
    int i = 0;
    int j = 0;
    int next[maxm];
    get_next(T,next);
    while(i < N && j < M)
    {
        if(j == -1 || S[i] == T[j])
        {
            j++;i++;
        }
        else j = next[j];
    }
    if( j == M ) return i-M+1;
    else return -1;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        cin>>N>>M;
        for(int i = 0; i < N; i++)
            scanf("%d",&S[i]);
        for(int i = 0; i < M; i++)
            scanf("%d",&T[i]);
        cout<<KMP(S,T)<<endl;
    }
    return 0;
}
View Code

我也不想说什么了1个月没有刷题出现缺少分号,主函数打错和在主函数中定义大数组导致程序崩溃我也是醉了,暑假加油!!!!!

posted @ 2015-07-07 15:36  乱齐八糟  阅读(130)  评论(0编辑  收藏  举报