.NET架构开发应知应会

  .NET程序是基于.NET Framework、.NET Core、Mono、【.NET实现】开发和运行的 ,定义以上【.NET实现】的标准规范称为.NET Standard

.NET Standard

  .NET标准是一组API集合,由上层三种【.NET实现】的Basic Class Library实现,更正式的说法,由统一契约集合构成的规范,这个集合确保了在不同【.NET实现】之间的可移植性,能让你的代码 run everywhere。

  .NET Standard 也是一个 target framework。如果您的代码针对的是.NET Standard的一个版本,那它可以在任意一个 支持该.NET Standard版本的.NET实现上运行。

 

[.NET实现]

  上图给出的是微软积极支持和维护的有三个主要的【.NET实现】:.NET Framework,.NET Core,Mono

  ①.NET Framework

    最早期的.NET 实现,.NET Framework 是为构建面向windows桌面环境而设计的,针对不同的应用程序形态设计了 WINFORM、 ASP.NET、WPF。

    4.5+版本开始实现.NET Standard:

https://docs.microsoft.com/en-us/dotnet/standard/net-standard  https://docs.microsoft.com/en-us/dotnet/standard/frameworks

    

  ②.NET Core

   是近几年微软拥抱开源的结晶,.NetCore是一个跨平台的【.NET实现】,因为原生实现了.NET Standard(完全没有版本包袱), 面向.NETStandard的代码可以在.NET Core平台上编译和运行。

   针对Web程序.NetCore准备了ASP.NECore框架, 定位是微软新一代高性能、开源、跨平台Web开发框架, 目前最新稳定版本为2.2

     另外.NetCore 3.0即将支持WINFORM、WPF, 这样将全面覆盖.Net Framework 支持的应用程序形态。

  ③ Mono   是一个微小运行时的 【.NET实现】,驱动 Xamarin,用于android,ios 等开发,支持目前所有公开的.NET standard 版本。

 

 本人近些年工作在.NetCore平台, 有一些宏观上的经验之谈供参考。

 

.NetCore部署目标的选择

  部署目标是在Target Framework Moniker中定义, 决定了程序的部署定位, 常见有如下2种:

  • netstandard

  • netcoreapp

  在实践中:项目早期可能是定位是 netstandard,后面随着项目演进,依赖的库越来越多,大部分都会变成netcoreapp.

  如前所述 .NetStandard也是 target framework, 期望在多个运行时(.Net Framework4.5+,.NET Core, XAMARIN)上都能运作的程序应该以此框架为编程目标。

<Project Sdk="Microsoft.NET.Sdk">
  <PropertyGroup>
    <TargetFramework>netstandard1.6</TargetFramework>
  </PropertyGroup>
</Project>

   伴随项目演进, 程序依赖的某些库可能只有针对 .NetCore的版本; 从生产实际看, 部署环境只会搭配一套.Net Core运行时, 所以后期项目很大可能性会演进成针对 .Net Core的运行时部署。

<TargetFramework>netcoreapp2.2</TargetFramework>

 

multi sdk、multi runtime选择策略

开发环境存在多SDK、多Runtime版本时,会使用什么版本呢?

  ① 当运行SDK命令,会使用安装的最新版本命令

SDK命令包括dotnet new/ dotnet run,即使项目生成文件被指定为早期版本的运行时 或 安装的最新版本SDK是预览版, SDK依旧使用安装的最新SDK版本

  ② 目标框架标记target framework monikers定义编译时刻的API

编译.NetCore程序的API是在项目文件的 Target framework Moniker中定义的,

<TargetFramework>netcoreapp2.0</TargetFramework>

<TargetFrameworks>netcoreapp2.0;net47</TargetFrameworks>

   ③ 运行.NetCore程序( 框架独立的.NetCore 程序 ), 在部署服务器上会适用版本前滚的策略

在项目文件中指定了netcoreapp2.0, 在部署环境中2.0.4 是安装的最新运行时版本, 那么就会使用2.0.4运行时版本

  ④ 发布自包含的程序,自包含的部署文件会内置指定的运行时

部署自包含.NetCore 程序时, 部署文件包含了.NetCore 运行时和程序依赖的库文件,自包含项目并不依赖 部署服务器上运行时环境,运行时版本选择发生在发布阶段,而不是在运行阶段。
目前 自包含.NetCore程序使用场景不多,一般用于需要将程序应用到复杂的多种客户环境中,这种部署方式可将运行时和依赖环境打包,不用去提前知晓客户服务器运行时。

  Tip: 针对策略① 有些特殊应用场景,如果项目需要使用早期的SDK版本,可在global.json文件中指定该早期版本,规避最新策略

{
  "sdk": {
    "version": "2.2.3"
  }
}

   本文没有大篇幅讲解 .NETCore SDK和CommandLine的用法,照葫芦画瓢即可,特别指出 部署目标的设定策略、服务器存在多SDK的选择策略, 读者可参照对比心中有数。

作者:JulianHuang

码甲拙见,如有问题请下方留言大胆斧正;码字+Visio制图,均为原创,看官请不吝好评+关注,  ~。。~

本文欢迎转载,请转载页面明显位置注明原作者及原文链接

 
posted @ 2019-07-03 15:58  有态度的小码甲  阅读(...)  评论(...编辑  收藏