bzoj 2843: 极地旅行社

Time Limit: 10 Sec  Memory Limit: 256 MB
Submit: 1077  Solved: 645
[Submit][Status][Discuss]

Description

不久之前,Mirko建立了一个旅行社,名叫“极地之梦”。这家旅行社在北极附近购买了N座冰岛,并且提供观光服
务。当地最受欢迎的当然是帝企鹅了,这些小家伙经常成群结队的游走在各个冰岛之间。Mirko的旅行社遭受一次
重大打击,以至于观光游轮已经不划算了。旅行社将在冰岛之间建造大桥,并用观光巴士来运载游客。Mirko希望
开发一个电脑程序来管理这些大桥的建造过程,以免有不可预料的错误发生。这些冰岛从1到N标号。一开始时这些
岛屿没有大桥连接,并且所有岛上的帝企鹅数量都是知道的。每座岛上的企鹅数量虽然会有所改变,但是始终在[0
, 1000]之间。你的程序需要处理以下三种命令:
1."bridge A B"——在A与B之间建立一座大桥(A与B是不同的岛屿)。由于经费限制,这项命令被接受,当且仅当
A与B不联通。若这项命令被接受,你的程序需要输出"yes",之
后会建造这座大桥。否则,你的程序需要输出"no"。
2."penguins A X"——根据可靠消息,岛屿A此时的帝企鹅数量变为X。这项命令只是用来提供信息的,你的程序不
需要回应。
3."excursion A B"——一个旅行团希望从A出发到B。若A与B连通,你的程序需要输出这个旅行团一路上所能看到的
帝企鹅数量(包括起点A与终点B),若不联通,你的程序需要输出"impossible"。

Input

第一行一个正整数N,表示冰岛的数量。
第二行N个范围[0, 1000]的整数,为每座岛屿初始的帝企鹅数量。
第三行一个正整数M,表示命令的数量。接下来M行即命令,为题目描述所示。
1<=N<=30000,1<=M<=100000

Output

对于每个bridge命令与excursion命令,输出一行,为题目描述所示。

Sample Input

5
4 2 4 5 6
10
excursion 1 1
excursion 1 2
bridge 1 2
excursion 1 2
bridge 3 4
bridge 3 5
excursion 4 5
bridge 1 3
excursion 2 4
excursion 2 5

Sample Output

4
impossible
yes
6
yes
yes
15
yes
15
16
 
 
好像是个裸的LCT,但是好久不打都有点忘了23333
/**************************************************************
    Problem: 2843
    User: JYYHH
    Language: C++
    Result: Accepted
    Time:1584 ms
    Memory:2124 kb
****************************************************************/
 
#include<bits/stdc++.h>
#define maxn 30005
using namespace std;
int ch[maxn][2],a[maxn];
int tot[maxn],tag[maxn];
int q[maxn],tp,n,m,f[maxn];
char s[11];
 
inline int get(int x){
    return ch[f[x]][1]==x;
}
 
inline int isroot(int x){
    return (ch[f[x]][1]!=x&&ch[f[x]][0]!=x);
}
 
inline void update(int x){
    tot[x]=a[x]+tot[ch[x][0]]+tot[ch[x][1]];
}
 
inline void pushdown(int x){
    if(tag[x]){
        tag[x]=0,swap(ch[x][0],ch[x][1]);
        tag[ch[x][1]]^=1,tag[ch[x][0]]^=1;
    }
}
 
inline void rotate(int x){
    int fa=f[x],ffa=f[fa],tp=get(x);
    ch[fa][tp]=ch[x][tp^1],f[ch[fa][tp]]=fa;
    ch[x][tp^1]=fa,f[fa]=x;
    f[x]=ffa;
    if(ch[ffa][1]==fa||ch[ffa][0]==fa) ch[ffa][ch[ffa][1]==fa]=x;
    update(fa),update(x);
}
 
inline void splay(int x){
    for(int i=x;;i=f[i]){
        q[++tp]=i;
        if(isroot(i)) break;
    }
     
    for(;tp;tp--) pushdown(q[tp]);
     
    for(;!isroot(x);rotate(x))
        if(!isroot(f[x])) rotate(get(f[x])==get(x)?f[x]:x);
}
 
inline void access(int x){
    for(int t=0;x;t=x,x=f[x]) splay(x),ch[x][1]=t,update(x);
}
 
inline void makeroot(int x){
    access(x),splay(x),tag[x]^=1;
}
 
inline int froot(int x){
    access(x),splay(x);
    while(ch[x][0]) x=ch[x][0];
    return x;
}
 
inline int link(int x,int y){
    makeroot(x),f[x]=y;
}
 
int main(){
    int uu,vv;
    scanf("%d",&n);
    for(int i=1;i<=n;i++) scanf("%d",a+i);
    scanf("%d",&m);
    while(m--){
        scanf("%s",s);
        if(s[0]=='b'){
            scanf("%d%d",&uu,&vv);
            if(froot(uu)==froot(vv)) puts("no");
            else link(uu,vv),puts("yes");
        }
        else if(s[0]=='p'){
            scanf("%d%d",&uu,&vv);
            splay(uu);
            a[uu]=vv,update(uu);
        }
        else{
            scanf("%d%d",&uu,&vv);
            if(froot(uu)!=froot(vv)) puts("impossible");
            else{
                makeroot(vv),access(uu),splay(uu);
                printf("%d\n",tot[uu]);
            }
        }
    }
     
    return 0;
}

  

posted @ 2018-02-22 19:55  蒟蒻JHY  阅读(309)  评论(0编辑  收藏  举报