Spoj LCS2 - Longest Common Substring II

题目描述

A string is finite sequence of characters over a non-empty finite set Σ.

In this problem, Σ is the set of lowercase letters.

Substring, also called factor, is a consecutive sequence of characters occurrences at least once in a string.

Now your task is a bit harder, for some given strings, find the length of the longest common substring of them.

Here common substring means a substring of two or more strings.

输入输出格式

输入格式:

 

The input contains at most 10 lines, each line consists of no more than 100000 lowercase letters, representing a string.

 

输出格式:

 

The length of the longest common substring. If such string doesn't exist, print "0" instead.

 

输入输出样例

输入样例#1: 
alsdfkjfjkdsal
fdjskalajfkdsla
aaaajfaaaa
输出样例#1: 
2



大概就是要你求最多10个串的最长公共子串,裸上后缀自动机。。。。

#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#define ll long long
#define maxn 4000005
using namespace std;
int a[maxn],c[maxn],tot;
int base=1,cnt=1,pre=1,n;
int f[maxn],ch[maxn][26];
int l[maxn],siz[maxn],ans=0;
char s[maxn];

inline void ins(int x){
	int p=pre,np=++cnt;
	pre=np,l[np]=l[p]+1;
	siz[np]=base;
	
	for(;p&&!ch[p][x];p=f[p]) ch[p][x]=np;
	if(!p) f[np]=1;
	else{
		int q=ch[p][x];
		if(l[q]==l[p]+1) f[np]=q;
		else{
			int nq=++cnt;
			l[nq]=l[p]+1;
			memcpy(ch[nq],ch[q],sizeof(ch[q]));
			f[nq]=f[q];
			f[q]=f[np]=nq;
			for(;ch[p][x]==q;p=f[p]) ch[p][x]=nq;
		}
	}
}

inline void build(){
	n=strlen(s),tot+=n;
	for(int i=0;i<n;i++) ins(s[i]-'a');
}

inline void solve(){
	base--;
	for(int i=1;i<=cnt;i++) c[l[i]]++;
	for(int i=tot;i>=0;i--) c[i]+=c[i+1];
	for(int i=1;i<=cnt;i++) a[c[l[i]]--]=i;
	
	for(int i=1;i<=cnt;i++){
		int now=a[i];
		siz[f[now]]|=siz[now];
		if(siz[now]==base) ans=max(ans,l[now]);
	}
}

int main(){
	while(scanf("%s",s)==1) build(),base<<=1;
	solve();
	printf("%d\n",ans);
	return 0;
}

  

 
posted @ 2018-02-22 10:31  蒟蒻JHY  阅读(200)  评论(0编辑  收藏  举报