HDU 1879 继续畅通工程 最小生成树

继续畅通工程
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。 
 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。 

当N为0时输入结束。
 

Output

每个测试用例的输出占一行,输出全省畅通需要的最低成本。
 

Sample Input

3
1 2 1 0
1 3 2 0
2 3 4 0
3
1 2 1 0
1 3 2 0
2 3 4 1
3
1 2 1 0
1 3 2 1
2 3 4 1
0
 

Sample Output

3
1
0
 
最小生成树有两种方法,一种是Kruskal算法,一种是Prim算法
因为学了并查集 先用Kruskal算法做做  
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;

struct node
{
    int st,ed,money,flag;
} a[5005];

int father[105];

int cmp(node a,node b)
{
    return a.money<b.money;
}


void Init(int n)
{
    for(int i=1; i<=n; i++)
    {
        father[i]=i;
    }
}

int Find(int x)
{
    if(x!=father[x])
    {
        father[x]=Find(father[x]);
    }
    return father[x];
}

int Union(int x,int y)
{
    x=Find(x);
    y=Find(y);
    if(x==y)
        return 0;
    father[x]=y;
    return 1;
}

int main()
{
    //freopen("input.txt","r",stdin);
    int n;
    while(~scanf("%d",&n)&&n!=0)
    {
        int res=0;
        Init(n);
        int k=n*(n-1)/2;
        for(int i=1; i<=k; i++)
        {
            scanf("%d%d%d%d",&a[i].st,&a[i].ed,&a[i].money,&a[i].flag);
            if(a[i].flag==1)
            {
                father[a[i].st]=a[i].ed;
            }
        }
        sort(a+1,a+1+k,cmp);

        for(int i=1; i<=k; i++)
        {
            if(Union(a[i].st,a[i].ed))
                res+=a[i].money;

        }
        printf("%d\n",res);

    }
}

  

 
 
 
posted @ 2016-07-26 23:24  Hyouka  阅读(261)  评论(1编辑  收藏  举报