HDU 4716 A Computer Graphics Problem

A Computer Graphics Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 58    Accepted Submission(s): 52


Problem Description
In this problem we talk about the study of Computer Graphics. Of course, this is very, very hard.
We have designed a new mobile phone, your task is to write a interface to display battery powers.
Here we use '.' as empty grids.
When the battery is empty, the interface will look like this:
*------------*
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
*------------*

When the battery is 60% full, the interface will look like this:
*------------*
|............|
|............|
|............|
|............|
|------------|
|------------|
|------------|
|------------|
|------------|
|------------|
*------------*

Each line there are 14 characters.
Given the battery power the mobile phone left, say x%, your task is to output the corresponding interface. Here x will always be a multiple of 10, and never exceeds 100.
 

 

Input
The first line has a number T (T < 10) , indicating the number of test cases.
For each test case there is a single line with a number x. (0 < x < 100, x is a multiple of 10)
 

 

Output
For test case X, output "Case #X:" at the first line. Then output the corresponding interface.
See sample output for more details.
 

 

Sample Input
2 0 60
 

 

Sample Output
Case #1:
*------------*
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
*------------*
Case #2:
*------------*
|............|
|............|
|............|
|............|
|------------|
|------------|
|------------|
|------------|
|------------|
|------------|
*------------*
 

 

Source
 

 

Recommend
zhuyuanchen520
 
思路:水题
 
代码:
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int t;
int n;
int bai;
int main()
{
    scanf("%d",&t);
    for(int i = 1;i <= t;i ++)
    {
        scanf("%d",&n);
        n = n / 10;
        printf("Case #%d:\n",i);
        printf("*");
        for(int j = 1;j <= 12;j ++)
           printf("-");
        printf("*\n");
        for(int k = 1;k <= 10;k ++)
        {
            if(k <= 10 - n)
            {
                printf("|");
                for(int j = 1;j <= 12;j ++)
                      printf(".");
                printf("|\n");
            }
            else
            {
                printf("|");
                for(int j = 1;j <= 12;j ++)
                          printf("-");
                printf("|\n");
            }
        }
        printf("*");
        for(int j = 1;j <= 12;j ++)
           printf("-");
        printf("*\n");
    }
    return 0;
}

posted on 2013-09-11 17:51  天使是一个善良的神  阅读(185)  评论(0编辑  收藏  举报

导航