[POJ2686]Traveling by Stagecoach

题目描述 Description

Once upon a time, there was a traveler. 

He plans to travel using stagecoaches (horse wagons). His starting point and destination are fixed, but he cannot determine his route. Your job in this problem is to write a program which determines the route for him. 

There are several cities in the country, and a road network connecting them. If there is a road between two cities, one can travel by a stagecoach from one of them to the other. A coach ticket is needed for a coach ride. The number of horses is specified in each of the tickets. Of course, with more horses, the coach runs faster. 

At the starting point, the traveler has a number of coach tickets. By considering these tickets and the information on the road network, you should find the best possible route that takes him to the destination in the shortest time. The usage of coach tickets should be taken into account. 

The following conditions are assumed. 

  • A coach ride takes the traveler from one city to another directly connected by a road. In other words, on each arrival to a city, he must change the coach. 
  • Only one ticket can be used for a coach ride between two cities directly connected by a road. 
  • Each ticket can be used only once. 
  • The time needed for a coach ride is the distance between two cities divided by the number of horses. 
  • The time needed for the coach change should be ignored.

输入描述 Input Description

The input consists of multiple datasets, each in the following format. The last dataset is followed by a line containing five zeros (separated by a space). 

n m p a b 
t1 t2 ... tn 
x1 y1 z1 
x2 y2 z2 
... 
xp yp zp 

Every input item in a dataset is a non-negative integer. If a line contains two or more input items, they are separated by a space. 

n is the number of coach tickets. You can assume that the number of tickets is between 1 and 8. m is the number of cities in the network. You can assume that the number of cities is between 2 and 30. p is the number of roads between cities, which may be zero. 

a is the city index of the starting city. b is the city index of the destination city. a is not equal to b. You can assume that all city indices in a dataset (including the above two) are between 1 and m. 

The second line of a dataset gives the details of coach tickets. ti is the number of horses specified in the i-th coach ticket (1<=i<=n). You can assume that the number of horses is between 1 and 10. 

The following p lines give the details of roads between cities. The i-th road connects two cities with city indices xi and yi, and has a distance zi (1<=i<=p). You can assume that the distance is between 1 and 100. 

No two roads connect the same pair of cities. A road never connects a city with itself. Each road can be traveled in both directions.

输出描述 Output Description

For each dataset in the input, one line should be output as specified below. An output line should not contain extra characters such as spaces. 

If the traveler can reach the destination, the time needed for the best route (a route with the shortest time) should be printed. The answer should not have an error greater than 0.001. You may output any number of digits after the decimal point, provided that the above accuracy condition is satisfied. 

If the traveler cannot reach the destination, the string "Impossible" should be printed. One cannot reach the destination either when there are no routes leading to the destination, or when the number of tickets is not sufficient. Note that the first letter of "Impossible" is in uppercase, while the other letters are in lowercase. 

样例输入 Sample Input

3 4 3 1 4

3 1 2

1 2 10

2 3 30

3 4 20

2 4 4 2 1

3 1

2 3 3

1 3 3

4 1 2

4 2 5

2 4 3 4 1

5 5

1 2 10

2 3 10

3 4 10

1 2 0 1 2

1

8 5 10 1 5

2 7 1 8 4 5 6 3

1 2 5

2 3 4

3 4 7

4 5 3

1 3 25

2 4 23

3 5 22

1 4 45

2 5 51

1 5 99

0 0 0 0 0

样例输出 Sample Output

30.000

3.667

Impossible

Impossible

2.856

数据范围及提示 Data Size & Hint

Since the number of digits after the decimal point is not specified, the above result is not the only solution. For example, the following result is also acceptable. 

30.0
3.66667
Impossible
Impossible
2.85595

之前的一些废话:是时候准备会考了。。

题解:dp[S][i]表示当前已经用了S集合的车票,现在在i位置的最优解。四层循环暴力搞,第一层枚举S子集,第二层枚举i表示当前点,第三层枚举接下来使用哪张车票,第四层枚举要到哪个点,转移很显然。

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<cmath>
#include<cstring>
using namespace std;
typedef long long LL;
typedef pair<int,int> PII;
#define mem(a,b) memset(a,b,sizeof(a))
inline int read()
{
    int x=0,f=1;char c=getchar();
    while(!isdigit(c)){if(c=='-')f=-1;c=getchar();}
    while(isdigit(c)){x=x*10+c-'0';c=getchar();}
    return x*f;
}
const int maxn=10,maxm=32;
const double oo=2147483647.0;
int n,m,p,s,t,ce=-1,a,b,c,all,horse[maxn],dis[maxm][maxm];
double dp[1<<maxn][maxm],ans=oo;
int main()
{
    while(scanf("%d%d%d%d%d",&n,&m,&p,&s,&t)!=EOF && (n || m || p || s ||t))
    {
        mem(dis,-1);all=1<<n;ans=oo;
        for(int i=0;i<n;i++)horse[i]=read();
        while(p--)a=read(),b=read(),c=read(),dis[a][b]=dis[b][a]=c;
        for(int i=0;i<all;i++)for(int j=1;j<=m;j++)dp[i][j]=oo;
        dp[0][s]=0.0;
        for(int i=0;i<all;i++)
            for(int j=0;j<n;j++)if(!(i&(1<<j)))
                for(int k=1;k<=m;k++)
                    for(int l=1;l<=m;l++)if(dis[k][l]>=0)
                        dp[i|(1<<j)][l]=min(dp[i|(1<<j)][l],dp[i][k]+(double)dis[k][l]/(double)horse[j]);
        for(int i=0;i<all;i++)ans=min(ans,dp[i][t]);
        if(ans==oo)printf("Impossible\n");
        else printf("%lf\n",ans);
    }
    return 0;
}
View Code

总结:状压DP中的循环顺序很重要,位运算优先级比较神奇,还是加上括号保险为好。

posted @ 2017-06-21 18:14  小飞淙的云端  阅读(133)  评论(0编辑  收藏  举报